Suddenly Octopi does not work. tried different solutions

I cannot connect to Octoprint webpage all of a sudden.
It was working ok last night, got back from work as I need to print something and wanted to heat the chamber

What did you already try to solve it?

Everything given on the webpage.
pi@octopi:~ ps -ef | grep -i octoprint | grep -i python pi@octopi:~ ps -ef | grep -i octoprint | grep -i python

Just returns the prompt.

Tried a cmfd line reinstall
Tried rebooting the Pi.

Complete Logs

octoprint.log (54.1 KB)

Additional information about your setup

OctoPrint version : 1.4.2
OctoPi version : 0.17.0
-Pi 4 using the octopi image.

Klipper, service is working correctly otherwise the display on the printer would not work!
Been running for weeks, not anymore!

That is a pretty ugly looking log! My first reaction is that your SD card has a problem. No networking and cannot load things from disk. Have you tried a different SD card? Take a look at /var/log/syslog to see what kind of errors the system might be throwing. You can do that with more /var/log/syslog

1 Like

I have networking as I can SSH into the Pi.
I use Klipper and have been putting off the install of MainSail, so I might give that a go this weekend.

Thnaks for looking, appreciated.

100% some kind of corrupted install, as OctoPrint is struggling to load pretty much anything.

I think you should either:

  • Flash a new OctoPi image, and start again
  • (the above is likely to be easier)
    Force a reinstall by SSH in, and run ~/oprint/bin/pip install --force-reinstall octoprint
  • If that doesn't work, you may need a new python environment, but at that point just get a new image.

And don't pull the plug on the Pi, if you do, always shut it down first - that's the no. 1 leading cause of corruption like that.