Sudo asking for password

What is the problem?

sudo asking for password

What did you already try to solve it?

tried google

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

i installed octorpint deploy and now the pi asks for a password when i use sudo , any help would be great .

Sudo always asks for the password after some certain time.

Either it is the default password raspberry, or you have took your own one when you setup OctoPi (you use OctoPi?). I bit more information here would be very appreciated.

However, you need that password to log into CLI/SSH. So you should know it.

yes i know the password i have to use it to log in via ssh but after logging in and doing sudo apt update its asking for the password ive nevver had that before.
but its all sorted now , i googled a bit more and found this .
Enable Passwordless Sudo on Raspberry Pi

passwordless is an extreme security risk. it asks for the password of the user you are logged in as.

ive never had to use a password for sudo before , to log into ssh yes but not using sudo apt update after being logged into ssh .

It's the common behaviour of Linux.

Maybe you had same special settings before?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.