Switch from 2.4GHz to 5GHz

What is the problem?
Even after changing config in octopi-wpa-supplicant.txt, OctoPi continue to connect to the previous 2.4GHz SSID.

What did you already try to solve it?
Tried to see if Raspberry Pi 4 actually "see" 5GHz networks and it does. I tryed to connect to to my 5GHz SSID (Livebox-ARAKELOV_5GHz) trought raspi-config but same result : after a reboot, RPi still continue to connect to SSID Livebox-ARAKELOV witch is on 2.4Ghz...
I verified and set again wifi location to FR (from I am)...

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

I have an operator router (Orange) witch is sending 2 SSID's (with same PW).
I've Octoprint running in the last version. Raspberry is updated from today.

Sorry, overseen something in your post, so I deleted mine.

I assume after changing the octopi-wpa-supplicant.txt you did a cold boot on the Pi?

"cool boot" ? You mean cut the power source ? No... just a "sudo reboot"... You think that it can be that ??

Just give it a try. Maybe in the WiFi chip there are still the old settings.

But shutdown first before unplugging...

Just tried. Shutdown then verified and still connected to previous SSID. New SSID is actualy still set in octopi-wpa-supplicant.txt... No clues... :exploding_head:

Anyhow, it was worth a try.

You may try to change the settings in wpa_supplicant.conf

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Sometimes the symlink between /boot/octopi-wpa-supplicant.txt and the one at /etc/wpa_supplicant/wpa_supplicant.conf can get broken. You can use sudo raspi-config to set the wifi from a kind of GUI as well.

Already tried but still same...

Remove the one you don't want - by the looks of it, it is going to try and connect to the first one, if that is 2.4G and it is successful, it won't even think about the other one.


That's it ! It worked :