Temp changing when starting Gcode?


The problem is that when I start a print octoprint goes through its start-up Gcode that I have built and heats bed to 75 and hotend to 240. Once that is all done then it will start the gcode file or 3D print at this point the bed temp drops to 65 and the hot end drops to 195 watch is my settings for my PLA.


I have got it down to its something to do with octoprint. I have tried running the same gcode or print off of pronterface and works with no problem no fulling temp to PLA heat.

I have tried running it with no start-up gcode. I have deleted all the plugins that I think would mess up temp adjustments.

Have you tried running in safe mode?

I have tried it in Safe mode and this still happens.

Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20211230143557.zip (215.2 KB)

Additional information about your setup

I'm running BTT SKR 2, OctoDash with an Ender 3 pro

Hello @Dustin_Wooldridge !

Sure? My bets have been on Spool Manager.

So have you just done this or the real safe mode?
Pure OctoPrint - so without 3rd party plugins - does not change any of the gcode commands.

You may enable the serial.log and post that one too, so then we can see what is going on during the communication

Yes i did do in safe mode, and now just running in safe mode Ill try another print and look at serial log and post.

octoprint-systeminfo-20211230160932.zip (240.2 KB)

I see where it changes on line 966?

Yes. And I'm quite curious about the tool command in 964:

2021-12-30 16:03:28,881 - Send: N30 T0*9
2021-12-30 16:03:28,890 - Recv: ok
2021-12-30 16:03:28,892 - Send: N31 M140 S65*100
2021-12-30 16:03:28,898 - Recv: ok
2021-12-30 16:03:28,900 - Send: N32 M104 S195*89
2021-12-30 16:03:28,905 - Recv: ok
2021-12-30 16:03:28,907 - Send: N33 M109 S65*107
2021-12-30 16:03:28,960 - Recv: ok
2021-12-30 16:03:28,961 - Send: N34 M109 S195*82
2021-12-30 16:03:29,015 - Recv: ok

Could the be some old start code in the slicer?

I'm going to try a different slicer and see if that makes a difference.

Yes, ok I tried a different slicing software and is seems to work ..... I'm going to reinstall simplify 3D and see if that works

Thanks for you help

1 Like

I have it running off of simplify 3D manually it has a built-in machine controller software and it runs fine. but running it from octoprint safe mode still changing temp values?

Because simplify 3D is putting those other temp values in the Gcode. Not octoprint
Save the Gcode from simplify3d to an SD card and pop that in the printer with octoprint disconnected. You'll get the same result

I have tried that and do not get the same results?.....I have to say Octoprint is a love hate relationship with me, I just reinstalled Octoprint on a new SD card and have no problems with temp adjusting at beginning of print. I was hoping that safe mode on octoprint would help in this situation but did not. It seems like ever time I get a new update for octoprint or a plugin a new problem occurs.

I just assume this:
The first temperatures are set in S3D start code and when it comes to printing, S3D inserts the temperature values that are set for the used filament.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.