Temperature Graph has corrupted background

What is the problem?

In the last day or so the temperature graph has begun to show strange triangles and shapes in the background. The graph still displays and seems accurate enough, but the background is all messed up.

What did you already try to solve it?

I rebooted the system and disabled the UI Customizer plugin.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log (612.3 KB)

Logs attached

Additional information about your setup

Server: 1.5.2
Running on Raspberry Pi 4

Weird. Is it the same pattern every time or does it change?

It changes. Always sharp geometric shapes like that. Haven't figured out a pattern. Just started a day or so ago.

Does it happen on other devices like your smartphone as well?
Never seen that before

Great question. Hadn't thought to check. It does not happen on other devices. Now I'm wondering if it's the PC and not octoprint at all. I did have to rollback some Nvidia drivers the other day on that PC.

Thanks for the troubleshooting tips! I hadn't even thought that it might be the PC


A reboot of the PC I was using to view the web interface fixed it. Silly of me to not even think that it might be a problem on the client side, being a web interface I was laser focused on fixing the server.

Thanks All!

1 Like