Tenlog TL-D3-Pro (Can't Control Second Extruder Or Print Via Cura)

What is the problem?

I am trying to control the second extruder via OctoPrint which is not working. I am able to update and retrieve the nozzle heat and value as long as I manually switch to the second nozzle at least once. But no matter what I do I cannot control the second nozzle. Just to put it out there I can control the first one without any issues.

What did you already try to solve it?

To fix the nozzle temp from properly being detected I added a script at the start of the connection in OctoPrint which is


This seems to have fixed OctoPrint from not displaying the secondary nozzle temp. However, I still cannot control the secondary extruder.

I have tried observing the terminal when I moved the secondary extruder from the printer LCD control screen, but the only output it providers is echo Active Extruder: 1.

Have you tried running in safe mode?

Yes I have.

Did running in safe mode solve the problem?

No it did not.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Log has been attached.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint Version: 1.5.3
OctoPi Version : 0.18.0
Printer: Tenlog TL-3D-Pro IDEX
Firmware: Not Sure? I Think?
Browser: Not applicable?
Operating System: Rasbian?
octoprint (1).log (74.4 KB)

Hello @Kva1992 !

For the first: Have you setup the printer profile in OctoPrint for 2 extruders?

Like this:

For the second: Have you installed the OctoPrint Connection plugin in Cura?

Yes to both of your questions. In the post, I believe I mentioned that I am able to detect both extruders I just cannot control the second extruder and cannot get the status of the second unless I use the gcode script after it connects to the printer.

As for cura, I have set everything up approved everything, and am able to send the file to cura but I cannot start the print in cura. Meaning cura is communicating with octorprint but for whatever reason is not detecting the printer is connect which I have no idea why.

Also thank you for your fast response. I will get a log posted as soon as I possibly can. Thank you again!

@Kva1992 did you ever resolve your issue?

Sadly I have not. Do you have a solution by any chance? I'm very close to writing my own firmware.

I have the same issue, I think. Got mine yesterday and SD card prints dual color shine, Octoprint 1.8.0 prints with the same extruder. Sad Face. :frowning:

This topic was started over a year ago and contains very little detail from the original author and none from @MarkyMac. If you want us to help, then I suggest you start a new topic. Pick a small object, slice it, and include the gcode in your new post. Enable the serial.log before you send the gcode to OctoPrint. Now fill out the template completely including a systeminfo bundle.

(Note: the blue links contain additional instructions)

1 Like

I can follow up with what I believe is user error, and user didn't post to this arena once it was resolved.
My error was to choosing the 2nd filament to run on The 2nd extruder (T1).
Once I properly sliced with my desired extruder, Merged the parts, and printed, I realized the err was inherent to the user behind the keyboard.
:slight_smile: Cheers!~

1 Like