Terminal not working

What is the problem?

When I type M503 ( or any other command ) into Octoprint Terminal I get the following message:-
Send: N8 M503*45
Recv: ok
Nothing more appears.

What did you already try to solve it?

Nothing because I don't know where to start

Have you tried running in safe mode?

I don't know how to do that

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

My system is:- Mac computer running os Big Sur, Raspberry Pi 4, Anet ET5 Pro. Cura slicer.

I can successfully print a model via Cura but I want to access the e.steps in order to change them but I am unable to do so. I am far from being technically proficient so be gentle with me.

Hello @MikeW !

When you wrote your post, on the right side of the edit window, there is the preview. The blue words (like safe mode) are links. They help you to find out more.

So you got a response from the printer and that shows the the terminal is working.
Why there is no report may either be a problem within the firmware or a plugin filters out the report.

1 Like

try M501
that should make the printer display values of stored params. m503 only works in marlin firmware

Thanks for your reply. I have just tried running in safe mode but the result is the same. I also tried entering M501 but that doesn't work either.

Have you tried M115?

M503 also works on other firmware:


In Marlin configuration there is this line:

When this is disabled, the firmware is not able to report the current settings. You must either enable this in your firmware build or ask wherever your firmware build is from to enable the option.