Tevo Tornado, communication error

Hi all,

What is the problem?

Printing stops due to communication error

What did you already try to solve it?

I tried to

  • change USB cable
  • change baudrate (in printer firmware too: 250000 to 115200 ==> same issue)
  • new installation of octopi on new SD card
  • add tape on D+ in USB port.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

octoprint (4).log (4.1 KB)

And in syslog at the same time:

Mar 28 21:18:28 octopi kernel: [ 8864.390719] ch341-uart ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

Octopi is always on undervoltage mode. i changed the power supply (but not official), same issue (power supply 5V/3A from amazon, now I wait a new one official)

I change the SSR of bed heating last week, because the last one remained closed at outlet and the bed reached MAX TEMP value. But now the bed heating work well.

Before updating octoprint and plugin, i never had this problem.

I have the firware updater plug in (and it's the only one installed). Maybe it's the cause of CH241 issue of syslog ??

Have you an idea to find the problem, because now, i miss one printing in two :cry:

Thank you (and sorry for my bad English)

Hello @PicPic35!

Could you also please share the serial.log (You maybe have to enable this logging before a print). There way much more informations inside that log concerning those issues.

Yes the serial logs was not activated.
I activated it, and start new print. Printing is finished correctly, but while the printer running, it stop few seconds and resume.
The Serial Log at this time:
serial (5).log (1.1 KB)

Good, but could you please share the whole file? There could be also issues beforehand that can lead to the problem.

serial (7).log (4.0 MB)

this the Log file, i removed lines after and before for respect the file size

So now, i tried to move the rpi position because i stuck it with double sided tape on the tevo controller box. The rpi is in metal case, and i guess maybe some interferences could be the cause. I have "always ch341-uart ttyUSB0: usb_serial_generic_write_bulk_callback - urb stopped: -32" error on syslog just before the printer stops. I haven't have trouble since.I will see if it's better

It seems that the printer has to perform lots of lots of tiny extrusion ways (I assume somthing round at the point). Even the way are that short, the printer board has to calculate them, but meanwhile new data comes in from OctoPrint until the buffer is full and the printer can work down the list. That takes a while.

You may reduce the slicing resolution in your slicer.

2020-03-29 14:42:34,759 - Send: N67462 G1 X137.225 Y159.564 E0.0559*80
2020-03-29 14:42:34,768 - Recv: ok
2020-03-29 14:42:34,773 - Send: N67463 G1 X137.223 Y159.497 F7200*75
2020-03-29 14:42:34,779 - Recv: ok

The actual X-distance is 0.02 mm, the Y-distance is 0.067 mm.