The directory name is invalid

#1

What is the problem?
When I run octoprint/octopi, I noticed that coincidentally I would get random error message appearing on my pc about different drives I have and the error message "The directory name is invalid"

image

image

These drives are to do with my usb ports/sd card port from my external SD card reader which currently don't have anything connected/mounted to them..

These error messages do not appear when octoprint is not running
and seems to popup when octoprint is running

So this can't be a coincident...

What did you already try to solve it?
nothing..since I don't know why it is occurring
so not sure where to troubleshoot.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

OctoPrint Version 1.3.10
OctoPi Version 0.15.1

#2

There's something weird or missing in your post.

OctoPrint is a server you can install on just about any computer, and which you control from a browser.
OctoPi is an operating system with OctoPrint preinstalled, which only runs on Raspberry Pi computers.

The dialogs you show are Windows 10 dialogs, so that suggests you are running something on your Windows 10 computer. You cannot "run" OctoPi on your Windows computer, but you do specify an OctoPi version.

So please explain, what do you mean by "running" OctoPrint/OctoPi ?

#3

Yes, I know those are windows 10 dialogs as I mention in my first post about it popping up on my pc..

Running Octopi as in running it on a raspberry pi and then using the web browser to interact with octoprint server/GUI.

Yes, I know you can't run octopi on Windows, hence why I said octopi (which is only installable on a raspberry pi)

If you need more info, please tell me what else I need to provide to help solve this weird problem.

#4

What browser do you use? Have you tried a different browser?

If the browser is accessing your I and K drives unprovoked, there's something wrong with your browser.

#5

I am using chrome.

I have use octoprint on different browser
but always have chrome active because it is my main browser..

Yeah this a weird problem.

And I know it can't be a coincident
because I run my pc all day with chrome active all the time
and never get this message..

But whenever the message starts appearing, octoprint is also happened to be running.
So therefore my logical conclusion it is somehow related to running octoprint.

Also if I tried to double click/access those empty drives in my windows explorer I would get a different message which is meant to mean that there is no memory card mounted

image

BTW I have 4 empty drives showing in explorer which corresponds to same number of memory card slots in my external usb card reader (which has no memory cards mounted) hence why it is blank.

And there is exactly 4 error dialog messages that appear.

#6

Run OctoPrint in Safe Mode long enough to verify that it's now happy.

If in Safe Mode it still does this, then you should visit your ~/.octoprint/config.yaml and look for any references to drive letters like these.

If it's happy in Safe Mode then review your plugins. Have you added something yourself that uses Samba or which tries to rsync data back/forth? Are you running any Chrome plugins/addons? Are you running some kind of antivirus program that would randomly try to access all drives?

When it appears, is it because OctoPrint is printing or idle?

Is it simply possible that when you are printing your printer is vibrating the table and that this then makes/breaks the USB cable over to your external USB card reader?