The guide to get HTTPS working doesn't work

What is the problem?
"unable to connect" error when trying to change any haproxy settings or connect via port 443

What did you already try to solve it?
Tried following this guide OctoPrint doesn't work when connecting via HTTPS

reqadd X-Scheme:\ https if { ssl_fc }

to haproxy.conf.
added schemeFallback:https to config.yaml.
Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)

Additional information about your setup (OctoPrint version, 1.3.11

I tried to search the Internet for a humorous graphic for "cough up a log" but alas, could not find one. And humor was not had that day...

So... when trying to reach your OctoPrint instance via https did you get a 404 or a 401 (sounds like the latter)?

2019-09-15 06:21:57,576 - tornado.access - WARNING - 401 POST /api/login (::ffff: 26.48ms

So we might assume that name resolution worked, that it found the haproxy instance... things happened... and then it threw a 401.

I'm not sure, because Firefox just gives me a generic "Unable to connect" error.

I'm not sure about what would throw a 401 but it's entirely possible that the credentials were entered incorrectly for the login page...?

It doesn't even get to the login page.

Perhaps someone else knows more about haproxy... @foosel