The OctoPrint server is currently not running (After a few weeks afk)

What is the problem?

"The OctoPrint server is currently not running"

My PiTFT screen is showing "Cannot connect to the printer", but more importantly I the OctoPrint UI isn't showing up on either octopi.local, nor the discrete IP address associated with it.

It was working fine several weeks ago, and I went away for training for about 2 months, and the interface no longer loads.

What did you already try to solve it?

I've restarted the pi several times, and attempted the commands that are shown on the "server not running page":
ps -ef | grep -i octoprint | grep -i python shows nothing.
sudo service octoprint restart also shows nothing.

I noticed this in my log also which is curious:
2021-09-12 23:34:05,983 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity state is currently: offline
2021-09-12 23:34:05,983 - octoprint.util.connectivity.connectivity_checker - INFO - Connecting to is not working
2021-09-12 23:34:05,983 - octoprint.util.connectivity.connectivity_checker - INFO - Resolving is not working

and, the chain of errors begins at:
2021-09-12 23:34:08,591 - octoprint.plugin.core - ERROR - Error fetching plugins from entry points

I tried asking on a few public discords, attempted googling a solution, and tried to see if I could figure it out based on the log, but couldn't make any progress.

Have you tried running in safe mode?

Yes, to no avail

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I can't access the System Information dialog because the interface isn't loading :frowning:

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.6.1
OctoPi 0.18.0

Raspberry Pi 3b+
BIGTREETECH SKR V1.4 Turbo 32bit Controller Panel Board for 3D Printer Compatible With12864LCD/ TFT24 Support 8825/TMC2208/Tmc2130 (with 5TMC2209)

Ender 5+
Chrome Version 93.0.4577.63 (Official Build) (64-bit)
Windows 10

octoprint.log (38.9 KB)

Bad marshal data is what is showing up in the logs. This is usually caused by some corruption on the SD card, it could be from the power being cut off at some point during a write.

You have two options I think, one is to attempt to revive it or just reinstall OctoPi.

You could try ~/oprint/bin/pip install --force-reinstall --no-cache-dir octoprint which will redo the OctoPrint core install, without losing any other data.

OK, I'll try that, thank you. I'd rather try to salvage it if at all possible, since I spent a bunch of time figuring out how to get everything configured and it was a bit of a pain.

When I try your suggestion, it says:

ERROR: You must give at least one requirement to install (see "pip help install")
WARNING: You are using pip version 20.3.3; however, version 21.2.4 is available.
You should consider upgrading via the '/home/pi/oprint/bin/python3 -m pip install --upgrade pip' command.

Any suggestion?

~/oprint/bin/pip install --force-reinstall --no-cache-dir octoprint

Sorry, the above command should be corrected - I've edited the old post accordingly. Forgot to tell it what to reinstall!

1 Like

And, I don't want to upgrade pip, right? it's 20.3.3, with 21.2.4 available. . .

MY HERO!!! It's back up and running again!


You could upgrade pip, if you wanted to - there's nothing that will break with the newer versions. Great to see it's back up & running.