The OctoPrint server is currently not running after Name change

What is the problem?

I get this error when I try to log in to octopi.local and the local IP adress of my Raspberry Pi 4. I didn't test it a few weeks and today I changed the Username and PW of my main account (pi). Therefore I had to kill a process from the root account (something with 3XX, can't remember anymore). After that I locked the root pw and updated & upgraded. Have no access to ~/.octoprint/logs/octoprint.log due to permission denied. Restarting the server didn't solve this problem either. The process doesn't show in the list so I have no idea what to do next.

Edit: I changed the name back to "pi" now it works as it should. But does anyone know if it is possible to change the name with still available service? Thanks for your help

What did you already try to solve it?


Have you tried running in safe mode?

Tried with ~/oprint/bin/octoprint safemode but get /.../python3: bad interpreter: No such file or directory
also with ~/oprint/bin/octoprint --safe , same error

In the path name it says first /NewName/oprint/... and after that it sais: /pi/oprint/... , so I think I have to change something to get in safemode. Maybe thats also the error for no server connection.

There was also no option in the "System" menu.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


There are several problems when you change the name and the permissions are one of them.

Depending on how you changed the name the users home folder wasn't changed and the ~ in ~/.octoprint/logs/octoprint.log refers to the new usernames home folder which doesn't exist or it refers to the old usernames folder for which it doesn't have permissions.

Now if you move everything to the new home folder and change the permissions you have also change the paths in other config files like for example the startup script /etc/systemd/system/octoprint.service.

Also when changing the permissions it's possible that you break something and/or make it insecure.

Tbh in my opinion it would be much easier to flash a fresh raspbian (raspberry pi os) image, create a new user and install octoprint with the help of this guide Setting up OctoPrint on a Raspberry Pi running Raspbian or Raspberry Pi OS

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.