"The OctoPrint server is currently not running"

What is the problem?
First my Raspi died. So I went to the store to get a new one. When I started it up with the same SD card I was using before I got the "The OctoPrint server is currently not running" message and I am now unable to use Octoprint.
On a few occations I have been able to access Octoprint. I have tried to update Octoprint since there's a message that says there's a new version available, but the update fails with the message "ERROR: Command "python setup.py egg_info" failed with error code -11 in /tmp/pip-install-bSCOQH/pylru/"

What did you already try to solve it?
I tried formatting the SD card and started over with a fresh install.
I tried a fresh install on another SD card. Both cards are SanDisk.
I tried running ps -ef | grep -i octoprint | grep -i python, but there is no response.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Octoprint version: 1.3.10
Octpi version: 0.16.0
Attached is the log.

Thank you for any help!


octoprint.log (90.2 KB)

Sounds like you have a corrupt image. Download the latest image and flash it to the SD card.

1 Like

Already tried that. Still the same issue.

Now the server works every now and then, but most of the times not.
If i run "ps -ef | grep -i octoprint | grep -i python" I get nothing. If I run "sudo service octoprint restart" and then ps -ef | grep -i octoprint | grep -i python I get "pi 738 1 99 20:31 ? 00:00:01 /home/pi/oprint/bin/python2 /hom e/pi/oprint/bin/octoprint serve --host= --port=5000
" back. Then most of the times the server still won't start or crashes.

a couple things. Have you done a sudo apt update and sudo apt full-upgrade in Raspbian yet? that will ensure you have the latest system files.
if it still doesn't autostart, then run "sudo systemctl enable octoprint"
Then "sudo systemctl start octoprint"

for fun, when the ps says it is running, do this:

curl -D - http://localhost/
curl -D - http://localhost:5000

Your log ends in a bootup process. The last few messages are all in the same second. It'd be really unusual if that was the end of the output. I suspect it was still generating output when you grabbed the log.

Here's a few lines from the bottom, which seems to indicate it is up. Maybe your browser is cached.

2019-05-26 13:20:17,794 - octoprint.server - INFO - Listening on

I did a sudo apt update and sudo apt full-upgrade and some things were updated. If I run sudo apt update again I get "All packages are up to date."

If I run sudo systemctl enable octoprint I get "octoprint.service is not a native service, redirecting to systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable octoprint"
When I run sudo systemctl start octoprint nothing seems to happen and it still doesn't work.

I ran curl -D - http://localhost/ and curl -D - http://localhost:5000. The responses I got are attached.

I also saved the log once again, but only from what was saved today.

The sympoms seems to be the following:
If the RasPi has been shut off and I turn it on, everything works just fine.
If the RasPi has been on and I reboot it, the error occurs. If I then let the RasPi cool down for a couple of minutes everything works again.
Could this point to a specific reason? Could it be a hardware error?

Thank you all very much for your help so far!

localhost.log (3.0 KB)
localhost5000.log (3.0 KB)
octoprint.log (14.8 KB)

At appears the reverse proxy isn't running, but you've got something that is messed up. You say it doesn't work if you "reboot it". You're talking about using 'restart' in the octoprint menu? Or 'reboot' in Octoprint? Or pulling the power plug?

In any case, I'd suggest a fresh SD card install. A fresh SD card shouldn't do that if you truly loaded it freshly. If not, it's hard to dig into. Maybe your network config?

Ah, sorry about that. By reboot I mean pulling the power plug. I only do this after I choose "Shutdown system" in Octoprint.
I did a test to see what happens when choose "Restart Octoprint" or "Reboot system" in the Octoprint menu. If I choose "Restart Octoprint" or "Reboot system" and the RasPi was recently plugged in everything works fine, but if the RasPi has had time to become warm the problem occurs, just like it does when I pull the power plug and plug it back in after a short amount of time.
It's just like it won't work when the RasPi is rebooted when warm. Does that make any sense?

I once again downloaded a fresh copy of OctoPi 0.16.0 and flashed it to another SD cart. The same thing happens, I can only reboot or restart when the RasPi is cold. Now, most of the times this shouldn't be an issue since it isn't rebooted too often, but it will be quite annoying if I have to cool down the RasPi before I can use it after updating or installing new plugins.

Tomorrow I can hopefully borrow another RasPi to see what happens with that.

The universe destroys a kitten everytime you do that.

1 Like

Well problem solved.

I really started to suspect that it was a hardware issue since Octoprint booted up just fine when the RasPi was cool, but wouldn't if it was warm.
I borrowed a friends RasPi and with that everything worked as it should, so I went to the store and got the RasPi replaced. So far so good!

Thank you everyone for your time!