The server encountered an internal error

What is the problem?

I get the following message when I try to open http://octopi.local/, the same error happens when I use the IP.

# Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

What did you already try to solve it?

I tried to update everything, octoprint, python. But it did not do anything.
As a last resort I would reinstall everything and start fresh.

I can connect without issues using PuTTy. I also know octoprint is running because my touch screen is also working.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Yes, but sometimes it does not want to boot in safemode.

Complete Logs

octoprint .log (244.6 KB)

I do not have a serial log as it was disabled. I tried enabling it but during startup I get a message that it failed to start serial logging. Resulting in this log:
serial.log (592 Bytes)

Additional information about your setup

OctoPrint version: 1.5.3 (0.1)
Octoscreen version:2.6 (20200128-12:42:20)
Ender 5 Pro (TH3D firmware)
Microsoft Edge Version 90.0.818.46 (Official build) (64-bit)
Windows 10 Professional 64bit

Everything was working just fine last week. I havn't changed anything, I was planning to add a tasmoda switch to the printer, but because I could not get on the site, I did not do it yet.
I am waiting on some connectors because the conenctors of my fan are in a bad shape, but other then this the printer was fine last week.

One of your third party plugins contains corrupted data and that is causing this. You'll have to figure out which one this is and uninstall/reinstall it.

As far as I can see it can only be one of these:

|  Bed Visualizer (1.0.1) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_bedlevelvisualizer
|  HeaterTimeout (0.0.3) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_HeaterTimeout
|  Themeify (1.2.2) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_themeify

Removing these fixed it. I took this moment to install alternatives and everything is up and running again. Thank you very much.