πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

The webcam server is currently not running

** Camera Model**
Not sure of the model but these are the units I have. The first was the first one installed and it worked fine until I moved the location on my printer. Next time I booted up it was not operating:

Amazon.com: Arducam Auto Focus Pi Camera, Autofocus for Raspberry Pi Camera Module, Motorized Focus Lens, Software Precise Manual Focus, OV5647 5MP 1080P: Industrial & Scientific

Amazon.com: Dorhea for Raspberry Pi 3 b+ 4 b Camera Module Night Vision Camera Adjustable-Focus Module 5MP OV5647 Webcam Video 1080p with 2 Infrared IR LED Light for Raspberry pi 3 Model B+ 2 B 4B: Computers & Accessories

What is the problem?
The webcam server is currently not running.

What did you already try to solve it?
I tried unplugging the ribbon cable on both the Pi board and the camera module board and reinserting into the port.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
Webcawebcamd.zip (196.5 KB)

Additional information about your setup (OctoPrint version, OctoPi version, ...)
I have also tried reflashing OctoPi OS on the SD card. Nothing changed.

Webcam log attached.

Thank you for the assistence.

The cam is not detected.

  • Is the CSI cable inserted the right way? The silvery contacts need to face away from the Ethernet connector!
  • Is the CSI cable fully seated?
  • Did you insert the CSI cable into the Display connector? It needs to be inserted into the CSI connector, which is the one closer to the Ethernet connector.
  • Is the other end of the CSI cable correctly attached to the camera board?
  • Is the camera module itself correctly connected to the camera board (see picture below)?

grafik

1 Like

The CSI cable is properly connected at both ends. I double checked that. I am wondering if I possibly damaged the CSI port on either the Pi board or the camera board. Is it possible to short the ports out? If so would switching to a USB webcam be a good solution?

I don't know to be honest.
I guess it's possible but I never saw a post of someone who said that the cam was broken after shorting something out.

Of course switching to a USB webcam would be a solution in that case - depending on the cam it can be worse or better than the pi cam :wink:

But let's try a few other things first.
run this command in ssh and post the output here

vcgencmd get_camera

Also I noticed that you got a hdmi cable connected. Are you using the Pi in desktop mode with the GUI?

Yes since I'm a Windows guy I am using the desktop mode and VNC into the interface. It's the easiest way for me. Do you think that could have something to do with the problem?

The result from that cmd is:
supported=1 detected=0

Which interface? Octoprint?
You can open it on any devices browser in your home network. You don't need vnc for it.
Just enter http://octopi.local, http://octopi or http://ip-of-the-pi in the address bar.

I was thinking that - if the gpu runs out of vram there can be cam issues.
But now that you posted detected=0 I don't know if that can be the issue.
Let's try to allocate more gpu memory anyway :slight_smile:

Edit the config.txt either on your pc or via ssh with sudo nano /boot/config.txt
Change the value in the gpu_mem= line to 512 (256 would probably also work but we just want to be sure).
Save the file (in nano with Ctrl + X -> Y -> enter) and either reboot the pi or put the card back in it and boot it up again.

Then run vcgencmd get_camera again. :crossed_fingers:

Okay, this time the get_camera returned:
supported=1 detected=1
But only with the second camera module I have (pic uploaded). The Picam module won't be detected. And still no webcam in OctoPrint.

By the way, I have to use Putty to access SSH screen. I cannot get there with my browser. Do I not have something setup properly for that?

No - that's correct. SSH is a completely different thing.
I was talking about the Octopint webinterface :slight_smile:

well that's something :slight_smile:
now I need again the webcamd.log so I can see what's going on

Rather than zipping the file I just took a copy/paste from the log file with the just the most recent entry at the top of the file:

Starting up webcamDaemon...

--- Configuration: ----------------------------
cfg_file: /boot/octopi.txt
camera: auto
usb options: -r 640x480 -f 10
raspi options: -fps 10
http options: -w ./www-octopi -n --listen 127.0.0.1

Explicitly USB device:

Found video devices:
/dev/video10
/dev/video11
/dev/video12
/dev/video13
/dev/video14
/dev/video15
/dev/video16
config file='/boot/octopi.txt':USB device was not set in options, start MJPG-streamer with the first found video device: /dev/video10
/root/bin/webcamd: line 184: printf: 0x: invalid hex number
/root/bin/webcamd: line 184: printf: 0x: invalid hex number
<13>Mar 7 00:00:01 root: Starting USB webcam
Checking for VL805 (Raspberry Pi 4)...

  • It seems that you don't have VL805 (Raspberry Pi 4).
    There should be no problems with USB (a.k.a. select() timeout)
    Running ./mjpg_streamer -o output_http.so -w ./www-octopi -n --listen 127.0.0.1 -i input_uvc.so -r 640x480 -f 10 -d /dev/video10
    MJPG Streamer Version: git rev: 5554f42c352ecfa7edaec6fc51e507afce605a34
    i: Using V4L2 device.: /dev/video10
    i: Desired Resolution: 640 x 480
    i: Frames Per Second.: 10
    i: Format............: JPEG
    i: TV-Norm...........: DEFAULT
    Error opening device /dev/video10: video capture not supported.
    Init v4L2 failed !! exit fatal
    i: init_VideoIn failed
    Done bring up all configured video device

Goodbye...

Starting up webcamDaemon...

I was just curious if you had any other suggestions for my webcam issues.

Sry I didn't feel well the last two days.

I would test one last thing - try a fresh octopi image and see if that works.

Oh my, I'm very sorry to hear that. I hope things are better now.

Funny you suggested that. After I sent my previous message I decided to do just that. So I reflashed the SD card, booted it in the pi, and resetup octoprint. This time I did not install the desktop GUI. So after the reinstall I still have the same issue. The vcgencmd get_camera reports back, supported=1 detected=1 but no streaming available in OctoPrint.

I really think something damaged the CSI port when I was handling the module. It was right after that when it stopped working.

Now I'm starting to feel better :slight_smile:

Sorry to hear that.
I'm of out of ideas - I guess the port is really broken

That's alright. Thanks for all your help. I got a USB webcam today and it's working great. Thanks again!

1 Like

My web cams didn't always seem to be picked up by my pi4 on octoprint. I appear to have fixed it by taking the tick out of the "auto connect on server startup". maybe give this a go.