Thermal runaway detected when using M600 command?

Not home now, so can't remember exact versions etc.

Anyways, I do have ender 3 pro what is running marlin 2.x and latest octopi.

I tried to print model what has 3 color changes, done with M600 command.
When printing via octopi, printer was reseted while I was doing filament change.


I moved same file to Sd-card and it printed OK.

And when printing normal models, zero thermal runaway problems, with or without octopi, so I think that there is some bug between printer <> M600 <> octopi?

My question is, how I can turn runaway detection off from octopi?
Not looking to disable it from firmware..


I have no experience with M600 but a serial.log would help us finding out what's going on.

You reaaaaaalllly shouldn't do that.
I'm not even sure if that's possible because your printer reported the problem so I guess it's triggered in marlin.

1 Like

In some occasions when the hotend hovers above the spot where underneath the heatbed the thermistor is located and both fans of the hotend are on 100%, the thermistor cools down rapidly, the thermal runaway protection is triggered.

1 Like