Thermal Runaway plugin causing M112 error with release 1.6.1 can it be fixed

What is the problem?

Information re : Thermal Runaway plugin causing M112 error with release 1.6.1, this plugin in was working fine on previous release.

What did you already try to solve it?

start in safe mode - re enable plugins one at a time , leave out thermal runaway = problem solved , i like the idea of thermal runaway protection though can it be fixed

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octopi 1.61, Creality CR 10 V2

Have you reported the issue to the plugin author?

no , didnt know what the process was i will contact him thanks

It looks like there may already be a bug report open, if you have anything to say jump in here:

1 Like

G'Day @piccy3d
This is a known issue, should be fixed by the latest release (V3.0.2).
See this issue for further details: [BUG] False thermal runaways detected/M112 sent for no reason after updating to V3.0.x Β· Issue #27 Β· AlexVerrico/Octoprint-ThermalRunaway Β· GitHub
Cheers, Alex.

I just had the same problem. It was driving me nuts trying to figure out if it was a hardware or software problem. Just uninstalled the thermal runaway plugin from my Octopi and that seems to have solved the issue.