Thermal Runaway when OctoPi is connected, no issues otherwise

What is the problem?
Hi there.
When I try to print using OctoPi, I get a Thermal Runaway error and my print stops. This happens consistently with the same STL / Gecode files.

When printing directly from SD card on the printer without the OctoPi connected I do not get this error, and all my prints finish succesfully.

When observing the temperature logging in OctoPi I don't see any irregularities (spikes or drops) that would warrant an issue.

Printer Ender 3
Cura 4.1.0 Slicer

As a note, this is my first 3D printer and my first time using OctoPrint / OctoPi. I have been printing things directly from the SD card for 2/3 weeks without any issues like this.

What did you already try to solve it?
I tried several different slicer settings as I initially thought there was something wrong with those settings that may be causing this.

Tested the same gecode both from OctoPi and from SD card on Ender 3

Logs (octoprint.log, serial.log or output on terminal tab, ...)
Attached Serial Log, OctoPrint Log, Gcode file, and print screen of temperature tracking.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, ...)

Printer Ender 3
Cura 4.1.0 Slicer
OctoPrint Version 1.3.11
OctoPi Version 0.16.0, running on Raspberry Pi 3 Model B Rev 1.2

serial.log (296 Bytes)
octoprint (1).log (232.7 KB)

Gecode and Screenshot (Unable to upload multiple links as a new user)

CE3_marker_25mm.gcode (1.2 MB)

No solutions for this? I'm now getting the same error on a CR10s Pro...

Hi!

Check your printer hardware that belong to the thermistors: Loose connection.

Also the logs would be quite handy.