Thumbnail commands M4010 give errors and Print are not working

What is the problem?

i connect my Qidi i-Mate S printer to an RPI with Octoprint.
When I make a Gcode File with my Qidi Slicer I can't print this files.
The Problem ist that the slicer add some Lines First with a thumbnail.
that are all M4010 commands. Over the Serial Port the Printer can't accept this commands.
give it a chance to Filter these commands automatically when Octoprint sent this Data to the Printer?

What did you already try to solve it?

When I manually delete all Lines with the M4010 commands it work, but the is tiresome.

I Found an old Plugin named "OctoPrint-Commfilter" but I don't know how it works.

Systeminfo Bundle

[octoprint-systeminfo-20221006162537.zip|attachment](upload://jw301KCB5g16Ki0Kps8FrcUvaaO.zip) (34.4 KB)

Additional information about your setup

Maybe try slic3r app instead of the Qidi slicer. It does not add those gcode commands.

In slic3r there is the capability to enter pre- and post- commands under the printer configs and maybe the same is available in the Qidi slicer. If so then modify those segments as needed to eliminate the problem lines.

In the OctoPrint Settings, Serial Connection, Firmware & protocol, Protocol fine tuning there is a text box for Ignored commands. If you add M4010 to that text box, does that help?

1 Like

I'd be interested in getting a copy of an exported gcode to see if I could support it in Slicer Thumbnails. I suspect it's similar to the weedo support I recently added.

1 Like

thanks a lot b-morgan! It works great.

that solves my Problem. Sorry that I not found this Option by my self.

Here a Benchy sliced with the Qidi Slicer

3DBenchy.gcode (1.0 MB)

i testet a Gcode File withe the Plugin, but it says they are no thumbnail in the File.

I found some code how to produce these lines. It may help.

Thanks, that does help some. Seems it's more closely related to the mks image encoding which is converting it to C header image style. Unfortunately, it's not exact as my existing parser for that format doesn't seem to work properly with it. Adding support in the plugin may be harder than I originally thought.

1 Like