Timeout communication errors

What is the problem?

Using Geetech A30T printer. The bed size is 320x320mm. When printing and using most of the bed size. I get communication errors. Mostly on the first layer. What is the time setting at that trigger this error. Let's say I am printing a box where the first layer is 280x280mm with a brim at 10mm from the model, if I print the first layer at 50% speed, I get the error. I bump up the first layer speed to 75%, no error occurs. I am using S3D.

What did you already try to solve it?

Swapped usb cable, sped up the first layer speed to 75%.

Have you tried running in safe mode?

No I have not
octoprint-systeminfo-20220805180856.zip (15.3 KB)

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Hello @andraisr !

These messages are all over the log:

2022-08-05 12:56:13,148 - octoprint.util.comm - INFO - Communication timeout while printing, trying to trigger response from printer.

You may check the USB connection from the Pi to the printer.

  • Recommended are: A good/high quality USB data cable with ferrite beads at the ends.
  • As short as possible.
  • Away from stepper motors and/or LC displays.
  • A well plugged in USB cable that can not be disturbed by moving parts.

If you have lots of long, slow moves, maybe the printer is not responding in time for OctoPrint's timeouts. The default timeout is 30 seconds if the 'busy' protocol is not supported by the printer, or 3 seconds if busy support is working. These are configurable in the serial settings.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.