Timeout configuration


First, congratulations for a great piece of software.
A couple years ago I installed Octoprint on a Raspberry Pi, but it was too slow.
Last week I decided to install Octoprint on a mini Windows PC and wow! It really shines!!

My only question is: how do I configure the timeout?

I am asking that because my printer probes the bed when it is hot and at the exactly time of the probing, it turns the heated bed off for precision and after that it waits for the bed to reach the programmed temperature again for the next probing point.

During the heating period between the probing points, the printer will not respond to Octoprint commands(a few seconds) and Octoprint disconnects from the printer.

I looked at the config.yaml, but I didn't find anything about the timeout configuration.

Thanks in advance

Hi @nickba!

Try this: OctoPrint Settings -> Serial Connection -> Firmware & Protocol -> Firmware fine tuning -> Advanced Options -> Long running commands



Thank you very much!!! Problem solved!!

1 Like