Total layer not displayed in Octoprint

What is the problem?

total layer is not displayed in Controll, 'Header' bar just "-" as in screenshot.

What did you already try to solve it?

updated Octoprint and all available plugins

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log (1.3 MB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version 1.5.3
Ubuntu 20.04.2 LTS
Dell Laptop

Marlin 2.0.x

Version 89.0.4389.82 (Officiell version) (64 bitar)

Dont realy know where to start so pls. point me in the right direction.

The dashes you are looking at is from the display layer progress plugin. You need to make sure that you have the layer indicator in your files, as mentioned in the plugin's settings.

They are in the gcode file like stated in plugin.
copied from plugin:

; LAYER: 3

From actual gcode file:
;Layer height: 0.1
;SETTING_3 50\nbottom_layers = 8\nbrim_line_count = 15\ncool_fan_full_layer =
;SETTING_3 5\ncool_min_layer_time = 8\ncool_min_speed = 12\ninfill_pattern =
;SETTING_3 lines\ninfill_sparse_density = 20\ninitial_layer_line_width_factor
;SETTING_3 nspeed_print = 45\nspeed_print_layer_0 = 20\nspeed_topbottom = 20\
;SETTING_3 nspeed_travel = 100\nspeed_travel_layer_0 = 90\nspeed_wall_0 = 35\
;SETTING_3 nspeed_wall_x = 35\nsupport_angle = 55\ntop_layers = 8\ntravel_avo
;SETTING_3 values]\nadhesion_type = brim\nlayer_height = 0.1\nmaterial_bed_te
;SETTING_3 mperature_layer_0 = 60\nretraction_combing = noskin\nspeed_slowdown
;SETTING_3 _layers = 1\n\n"}

only difference is the space between colon and number.
using Cura 4.8.0 for 'slicing', cant find any parameter to change to include a 'space'.

I solved it myself

And the solution was?

1 Like

use right regular expression

1 Like