Totaly Lost No Files into OctoPrint


#1

What is the problem?
Where do I see to select the files to be printed or sliced? (in Octoprint) How do I get them there with a Raspberry Pi? I can swap an SD crd but I don't want to do that I want to know how to see the Printer files locations through the Pi. No where to be found. See the file area in the OctoPrint (OP) it says files, but nothing is there. I see in Pi the file locations for OP but the directory I created under fie in PO doesn't show up anywhere in Pi. How to you get the files int PO from Pi?

What did you already try to solve it?
Spend 2 weeks reasearchng trying and crying. Got Printer 3 weeks ago, have the ability to heat it up and home. No way to see Pi or other file locations to move the files to be sliced.
Additional information about your setup (OctoPrint version, OctoPi
Seems pretty simple up til now. I see the Pi and in Pi the OctoPrint Location and File folders. But nowhere can I find the connecting file or app or whatever to print anything
version, printer, firmware, octoprint.log, serial.log or output on
terminal tab, ...) Using an Ender 2

All help appreciated, everything thing is there, just none of it is connected or visable


#2

It sounds like you're trying to SSH the files into Octoprint

Try using the IP address in a web browser instead. That's where the Octoprint interface lives


#3

This is a classic chicken and egg problem. :smile: Once you have OctoPrint displaying in a browser, you can go to settings (wrench at the upper right) and then click on Folders from the list on the left and see where OctoPrint is looking for its files.

Of course, once you have OctoPrint displaying in a browser, the Files section on the left side has buttons and instructions to get files uploaded for printing.


#4

Thanks for getting back to me,

Found the upload button and my Raspi showed up and all is well.

Now onto the camera . . . . . 3 days no connection with Octoprint. Can take pictures with it, save em but not with OctoPrint. Need step by step, click this enter that instructions that do not exists anywhere on the web. (I've looked)

So can you help me there?

Thanks

Chip King
Control Systems Specialist
Caroga Lake NY
518-632-4799 H
518-705-0731 C <<


#5

What camera ?

How is it connected ?

What is it plugged into ?


#6

Thank you so much for getting back to me I managed to get my camera working the problem I think was syntax.
It took a few tries to get the server to run I will have it working thank you very much now I have printed something and I'm trying to figure out how to see the time lapse. Again appreciate very much have you getting back to me. I am sure to have more questions thinking about what I need to do.
I live upstate NY, where are you?

Thanks again

Chip

Sent from my Verizon 4G LTE Smartphone


#7

I'm in Upstate NY, Saratoga area


#8

Hey there, got a question, If I run my print with out the camera it finishes, if I run Time Lapse I get 1/3 to 1/2 way done and it quits the servers and shuts down. Cam is a basic USB web cam 640x480 when running without camera CPU usage is 23% to 45% when running camera it is 23% to 60% it will quit in the first minuets of go an hour, no set timing to quitting on server loss.

The TL photo does work and capture what it is running when it is running, So that part is figured correctly

How to I troubleshoot this and correct this?

Could you give me an idea of what I am doing wrong?

Chip King
Control Systems Specialist
Caroga Lake NY
518-705-0731 C <<


#9

First thing I'd check is the amount of free space, "df -kh". Time Lapse movies need a fair amount of temporary storage which can be (is) deleted after the movie making is complete. You may need to monitor the free space as you print to see what the actual usage looks like.


#10

Thank you for the heads up I went ahead and ran the command and I can see the memory usage change between having the camera plugged in or not. The question now is what do I do with that information and how do I change it in order to make it function the way I need to.
I appreciate the time you've taken to answer my question any further help is muchly appreciated

Sent from my Verizon 4G LTE Smartphone


#11

Hi Brad thank you so much for taking the time to get back to me I managed to see what I was doing wrong and at files loaded have printed first item machine works good then when I hook up camera to do time lapse if freezes and does not continue to run, and shuts the server off. Any suggestions? Thanks again

Sent from my Verizon 4G LTE Smartphone


#12

Post the output of the "df -kh" command here for starters. Please try to understand that we are not omnipotent. If you provide no details, we provide no answers.

How big is the (micro) SD card in your Raspberry Pi? Which model Raspberry Pi? What model camera? How is it connected to the Raspberry Pi? What model printer?

I am assuming you can connect to the Raspberry Pi using SSH, correct? How does the Raspberry Pi connect to your network? Please define "freezes" in more detail. Does it respond to commands from OctoPrint? Please describe "shuts the server off" in more detail. What do you have to do to get it back "on"?

Please provide any other details that might be helpful in solving the problem. This includes details of what steps you took and the results even if it failed.


#13

Hi Brad!!

Thanks for getting back to me. I do understand "Please try to understand that we are not omnipotent. If you provide no details, we provide no answers."

I am only a few weeks into learning this system, so much to learn! Fortunately it's easy to understand, just not used to the syntax issues (fat fingers) and not knowing the commands yet.

So, on to the meat and potatoes of what I am dealing with!

(How big is the (micro) SD card in your Raspberry Pi? Which model Raspberry Pi? What model camera? How is it connected to the Raspberry Pi? What model printer?)

Printer = Ender 2

Camera = Generic USB Cam, no name on it, no tilt or zoom, just the camera, bought it at the same time I bought the system. Supposed to be what should work with it. (Got everything from Geekbuying.com Plugged into USB Port

Pi = **Raspberry Pi 3 Model B ** 32Gig SD installed

Followed instructions from Octoprint to run OctoPrint from a server setup on the Pi.

Using Toshiba Netbook connected local > 169.254.53,79 (computer)

169.254.247.63 (Pi) (Not WiFi Connected)

Also setup as per instruction to run camera server. see it on the user interface, clean and clear 169.254.247.62:8080/?action=streaming and the snap shot address is 169:254;247;62:8080/?action=snapshot with capture location setup to http://127.0.0.1:8080/?action=snapshot for the time lapse. It all works

The following command without the server running no camera interface


#14

Try and slow down, details are a good thing but typos can ruin them.

Did you install OctoPrint on an already existing operating system on the Raspberry Pi or are you using OctoPi (which has OctoPrint pre-installed)?

Are the laptop and the Raspberry Pi connected to the internet? I ask because the IP addresses are not ones normally seen when an internet connection (i.e. a router) is present. Does the laptop have WiFi that is connected to the internet and you just have an Ethernet cable between the laptop and the Pi?

Because of the multiple typos in the IP addresses, I can't tell if all the addresses for the printer are the same or are they actually different?

The following command without the server running no camera interface

I think we got disconnected... Can you hear me now? :smiley: