Touchscreen not responding to touch

What is the problem?

After upgrading to new version my Official Raspberry 7 inch screen will no longer respond to touch inputs.

What did you already try to solve

Reinstalled and updated more than once. Also changed to SD card with Raspberry OS and everything works. As all ready stated everything work great until I upgraded.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (64.4 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


To what? OctoPi or OctoPrint or one of the plugins?

I used the Raspberry Pi imager to get the 1.9.0 of OctoPrint with OctoPI included. No plugins were installed and the Touchscreen was not responsive. Thought about reinstalling the previous version everything worked fine with it. Just to be clear mouse and keyboard input works fine.

Which image of OctoPi did you use?

Did you do an sudo apt update and sudo apt upgrade to make sure the drivers for your touchscreen are up to date? You should be able to find installation instructions and/or a manual for your touchscreen.

OctoPi is just Raspberry Pi OS Lite with some additional packages installed. The base OS is responsible for providing the touchscreen device drivers and software.

I tried them both. The touchscreen did not respond to touches on either of them. I did use sudo apt update and sudo apt upgrade also. The touchscreen is the official Raspberry PI 7 inch screen. I have also tried two different Raspberry OS I have on other SD cards and they work fine. Touchscreen has full function when they are used. Thanks I know its more than likely something right under my nose :roll_eyes:

Continuing the discussion from Touchscreen not responding to touch:

Maybe I should maybe make things a little clearer. Before OctoPi 1.0.0 with Octoprint 1.9.0 I was running the previous versions along with the Octodash plugin. Touchscreen and mouse input work fine no problems. When I installed OctoPi 1.0.0 with Octoprint 1.9.0 using the Raspberry imager on reboot I SSH the OctoDash plugin. Same process as before and same hardware. I have no mouse or touchscreen input. I have replaced my SD card with another OS and everything works fine. Touchscreen works fine So any help will be appreciated. By the way I do recover mouse input by installing the user GUI using SSH. no touch input though.

Let's try another aproach then. Do you use a webcam on the pi and if yes which one?

yes its a older logitech can not find a model number on it.

I used this quote from your original post and entered it into Google Search. The results show numerous topics on multiple websites including

I suggest you do some research on those sites or even open a topic specific to your issue. If you do open a new topic, you can mention your OS is OctoPi but include the output from cat /etc/os-release so anyone reading your post will know that OctoPi is based on "Raspberry PI OS Lite". You should also mention that you have a USB camera installed (see below).

As for identifying your camera, unplug it, type sudo dmesg -c, plug it in, type dmesg and post the output here.

This appears to be an OptoPi/OctoDash specific problem, since I'm seeing the exact same issues.

If I do a clean install of Raspberry Pi OS (2023-05-03) directly from Raspberry Pi Imager, everything works fine. The touch screen works exactly as expected, even before I do an update/upgrade.

If I install OctoPi (stable) 2023-06-27, from the same Raspberry Pi Imager, and then update/upgrade before rebooting and running the OctoDash install script as the docs say, the OctoDash wizard is shown, but there is no response to the touch screen.

I was previously happily running Raspian+OctoPrint+TouchUI on the same hardware, but I figured enough had changed that a fresh install was worthwhile, and now I'm wondering if I should have just installed OctoPrint and OctoDash on Raspberry Pi OS lite, as I did last time around (when I couldn't get OctoPi to work with TouchUI).

I haven't got as far as adding my camera back, or even connected it to my printer, since there is little point until I can get the touch input working.

Since you have an OS install that works and an OS install that doesn't work, I'd suggest you do an lsmod >works and an lsmod >fails and compare them. Use WinSCP, a USB flash drive, or (my favorite) a USB SD card reader/writer to get both files in the same place.

You might also find some useful information in these topics,,

I'd be interested in the lsmod output if you start with Raspberry Pi OS Lite. I'm guessing that the necessary drivers are included in files installed with the desktop (which can be added to OctoPi via an included script).

Diffing the output of lsmod between Raspberry Pi OS and Raspberry Pi OS Lite (2023-05-03) shows almost no difference. The only Modules added being rfcom and i2c_dev, which don't appear relevant.

Diffing the output of lsmod between either of these and OctoPi (stable) 2023-06-27 shows many differences though. OctoPi adds cryptd, cryptd_simd, drm, nfnetlink, nf_tables, nft_compat, xt_DSCP & xt_tcpudp, while removing joydev, libaes.

These differences (especially the inclusion of deprecated modules) suggests that OctoPi is based on an older version of Raspberry Pi OS Lite than the current one.

Tonight I will try adding OctoPrint and OctoDash to my Raspberry Pi OS Lite uSD and see if that fixes the problem. I'm not even sure why I'm bothering with OctoPi after my previous, equally frustrating, attempts to use it.

The adapter board communicates to the RPi using the 50pin cable. From the RPi schematics, the connector for this cable has signals for DSI and I2C.

The touch portion of the screen uses I2C so that module may be relevant. Also sudo raspi-config, Interface Options, I2C, to enable the loading of the kernel module might also be relevant.

Enabling I2C on OctoPi made no difference, sadly, so I went back to my Raspberry Pi OS Lite plan, which just worked out of the box.

Also, it turns out that OctoPi is indeed based on a very old version of Raspberry Pi OS, so I think it's time to just accept, twice bitten forever shy.

What version of OctoPi were you using? It should be reasonably up to date - 1.0.0 was released just 6 months ago, so I think that the oldest RPi OS image it used is the same age. It's then kept up to date with sudo apt update and sudo apt upgrade as well. It's intriguing to see it didn't work.

Hi all,
I posted this issue on the OctoPi GitHub with some troubleshooting information, and did not spot this thread.
( Official 7 Inch touchscreen not detected Β· Issue #821 Β· guysoft/OctoPi (

I am having the same issue, and am unable to touch and control the backlight.

If you'd like me to create a new thread instead, please let me know.

I had exactly the same problem, exactly the same hardware etc. Id love to claim credit for the answer, but i stmbled upon it where Googling the answer and this worked for me

Navigate to /boot on the Pi and edit config.txt

Cd /boot
Sudo nano config.txt

Comment out this line in the config file by adding a # at the start and save your changes


Reboot the Pi

Touchscreen should now work


Hi Steve,

Cheers, That worked!
I haven't read that anywhere else but here. Glad there's a solution :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.