Touchscreen Terminal not updating?

What is the problem?

The OctoPrint Terminal on my touchscreen is no longer updating the active command during prints. Seems to have occurred after my recent update to 1.6.

However, my remote computer over the local network is showing the terminal screen updating. I can start the print from my remote computer and I can see the commands for the print start flowing but the touchscreen terminal immediately stops. The touchscreen will show the temperature reports for the bed and hotend as it is heating up but as soon as the print command is sent, it stops.

What did you already try to solve it?

Tried turning Autoscroll off and on with the touchscreen. No change.

Have you tried running in safe mode?

Not yet.

Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 918192128
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.15.1
env.plugins.pi_support.throttle_state: 0x50000
env.python.pip: 9.0.3
env.python.version: 2.7.13
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.0
printer.firmware: Marlin 2.0.4 (GitHub)
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Are you using the regular UI for your touchscreen? Or a plugin like TouchUI?

There were some issues with OctoPrint 1.6.0 and TouchUI so that may be the issue.

I do use TouchUI.

Is there a thread regarding this? My descriptive search did not yield anything regarding this.

Thank you!

OctoPrint 1.6 : messed up dosplay on TouchUI · Issue #494 · BillyBlaze/OctoPrint-TouchUI · GitHub and TouchUI menu gone after 1.6.0 update

Not entirely sure if its the same issue but it's similar - mostly because ToichUI hacks the UI so much it is very prone to breaking. UI Customizer provides a great way of doing responsive UI if that is what you are after, as an alternative.