TouchUI only visible when pressed on with stylus

What is the problem?
PI 3b+ running octoprint. with a 3.5 inch SPI touchscreen from UCTRONICS.

boots and loads fine. and the screen works fine when touchUI is disabled, however on boot up I gat the TouchUI logo for 5-10 seconds or so followed by a blank/black screen with a (non flashing) cursour in the top left corner. If I press the screen with my finger/stylus I can see the TouchUI in there end even interact with it. But as soon as I release pressure it goes back to black.

What did you already try to solve it?

All drivers, octopi, and raspbian are updated (today). Tried the TouchUI calibration as described on the touch UI github, but it gave me fatal server errors about "resource temporarily unavailable". No idea if this is the problem or not. I can load the native raspbian desktop and navigate around it with the touchscreen. and it works and displays fine.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

I have no idea how to make a log, frankly I am way over my head already but treading water so far. Here is the text in my current terminal window.

https://1drv.ms/u/s!Apsj12_fBtu0ghvxoZNgZE0bpNXV?e=K9EQOe

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)