TP Link Archer T2U, ralink mt7610u? Install for Pi2

I am running an RPi2B+, And obviously that has no WiFi, I have a TPLink Archer T2U ( TP Link AC600) that I can use for a Wireless connection.

Downside is I cannot for the life of me find a working driver for the current kernel AT ALL. I have tried every single avenue I can think of to install this.

I have tried 3 different repo's, and multiple guides on the internet to no avail. Unsure if i am allowed to post links to the guides I have used, but I'll post one anyway.

Tried MrEngmans Script which works, But upon reboot it will crash the system

Your Pi revision number is
You have a Pi B v2.0
Checking for a mt7610 wifi driver module for your current kernel.
There is a driver module available for this kernel revision.
Downloading the mt7610 driver.
Installing the mt7610 driver.

Installing driver module mt7610u.ko.
install -p -m 644 mt7610u.ko /lib/modules/4.14.79+/kernel/drivers/net/wireless
Loading and running the mt7610 driver, mt7610u.ko.

Octoprint version ( Current )
Printer - Ender 5 Creality

Apparently TP-Link chose not to create a Linux-based driver for this.

After flashing a clean Octoprint, and using Dr Engmans script, It installed the driver and actually shows in ra0, I even now get a green light! Downside is it doesn't connect to my router :confused:

At a time like this I think "how much is an hour of my time worth?"

You can buy a Raspberry Pi 3B for $35 which includes wifi on the board.