Tronxy X5S won't connect after update

New Tronxy X5S was connecting but after update to 1.3.12 it will not connect. Error: State: Offline (Error: Printer keeps requesting line 4 again and again, communication stuck)
All updated including Python. I tried three different SD cards in my Raspberry Pi 3B which is controlled from a Windows 10 machine. My Anet A8 updated on the same day, in the same way, works properly but has no camera. Ordered new camera to see if that's it.

Log File.........................

We need the logs :slight_smile:

octoprint.log (30.0 KB)

The serial.log also please :wink:

Which baudrate are you using?
Try to set your firmware to 115200 if you're using a higher rate

Tried 115200 and AUTO.

I mean change the value in the marlin config if necesarry :slight_smile:

It looks like a similar problem on Anycubic printers. The solution for those would be this

But I'm not sure if it's the same issue here.
We should wait for @foosel or any other person with a better idea :slight_smile:
Please provide the serial.log - she will probably need it

I am (was!) using the X5S as it was delivered. I have not seen Marlin or changed anything from new.

Ooooh I'm sry I thought you also updated your printers because of this part

Well then back to the logs :slight_smile:

serial.log (148 Bytes)

Open the log and you will see a special message for you :wink:

serial (2).log (6.6 KB)

The only way my X5S will connect is to set both the port and baud rate to "Auto". And there is a setting I ran across a while back to increase the wait time. This made connections reliably since then. Sorry don't remember the exact setting and can't trace it down right now as my pi decided to go on vacation for some reason. Oh and the the baud rate worked out to 115200.

Thanks for that. I am using AUTO for both but no joy. Baud rate at 115200. I two spare Pi units and both behave the same.

New camera fitted to the Anet A8 and all OK. The camera was "en panne". So only the Tronxy broken.

Now trying to flash the board which is based on an STM32 chip. I have installed STM32FLASH but after an hour of trolling about with putty I am unable to find the path to this which is needed in the plugin setup. Any ideas as to where it is hiding ?

The Linux find command is useful in cases like this:

sudo find / -name foo 2> /dev/null

This will look for a file named foo anywhere on the root partition, redirecting rights errors to the bit bucket.

Thank you for that. I am good with Mac and Windows but less experienced with linux. Searching using Putty is awful.

Still no joy. I simply cannot print with Octopi. Ihave some progress in that I can see the camera and the controls work through the keyboard of the remote computer. Furthermore I am occasionally able to launch a print and the machine will come to life indicating a temperature rise on the graph but no rise in the actual temperature of the machine. The system then hangs. So some commands are getting through but not others. I have had this machine half a year now and have yet to print anything.

If the graph indicates an increasing temperature, then it's your firmware which is returning that information. Visit the Terminal tab, toggle off some of the information but leave the temperature-related lines in the log. Watch what's happening. Each line returned from the firmware is interpreted by OctoPrint as reality.

Copy/paste one of those lines here, having just set the temperature in the Control tab. (Some of the odd firmwares provided by manufacturers deviate from the expected style of reporting.)

Thanks for the reply. The firmware is not actually replying at all. The temperature graph goes straight to 60 for the bed and 200 for the filament and nothing else happens.
The fans come on as if printing has started but nothing else. This printer is the newest X5ST-400 and it's using an STM32F103 chip.

Recv: wait
Send: N232 G1 X93.183 Y125.978 E12.84375111
Recv: T:21 E:0 B:-47
Recv: T:21 E:0 B:-45
Recv: wait
Send: N233 G1 X92.221 Y124.900 E12.91583
Recv: T:21 E:0 B:-45
Recv: T:21 E:0 B:-45
Recv: wait
Send: N234 M105*34

These are a few lines from the console.