Trouble Accessing Octopi UI via Web Since 1.5.2 Update

What is the problem?

Since running the update installer for 1.5.2, I've been having trouble getting my browser to talk to my Octopi. I will run a print, and it will work just fine, but after the print has completed, I can no longer see the Octopi through the browser. It takes up to an hour for the browser to access the server again, regardless of whether I restart the server or not. Frustratingly, sometimes when I restart the server, I hear the the telltale "click" of the server connecting to my printer, but the browser will say "Looks like something went wrong during startup, the server is gone again. You should check octoprint.log."

What did you already try to solve it?

I am very much a newbie when it comes to this sort of thing. I haven't known what to try aside from restarting the server and trying to run it in safe mode.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

Logs are located in my Dropbox.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint version 1.5.2
Raspberry Pi Model B Rev 1
MacOS Catalina 10.15.6
Firefox & Chrome
Ultimaker 2+ Tinker Marlin Firmware

Looks like there is a memory issue on the API.

I might suggest that the install has got corrupted, since it's pretty much impossible to do this from multiple API calls that quickly. What else is running on the Pi?

If you open 2 SSH windows, run htop to view the system resources, then in the other window try and start the server. Something is using all of the memory on your Pi, now we need to find out what.

It was a vanilla installation. I've never had anything else installed on the Pi. Here is what htop (eventually) returned:

I think you might just need a newer Pi. Your one seems to only have ~128MB RAM? Even a Pi Zero would be more powerful.

I don't know what else can solve this really, there is no memory leak as such but it is just not coping. Surprised it worked on previous releases? Maybe whatever was added has increased memory footprint slightly. If you can get in at all then disabling some of the plugins might make it a bit lighter.

1 Like

Thank you!!! I will go ahead and order a new Pi. This is super helpful and I really appreciate your insight.

I just wanted to let you know that my Pi 4 just arrived and it's all set up and working beautifully!