Trouble getting started with anything

What is the problem?

Tonight I have flashed the latest version of OctoPrint (1.8.7, and OctoPi 1.0.0, according to the command window) to an SD card and put it in my RPi 4b 2GB, which is installed in a Smartie Pi Touch 2 screen.
I used the Raspberry Pi website’s flash thing to do this (I am a complete noob and have been reading all night trying to figure out what I’m doing wrong, already ran into the four fast four slow issue, but using the version of OctoPrint without Klipper fixed that).
After having to connect a TV, a keyboard and a mouse to the Pi because the touch screen wouldn’t work, I finally got somewhere (the Pi was not the problem; NOOBS ran on it perfectly with or without peripherals) and it booted up.
I installed the GUI using instructions I found on All3DP, and it worked. But now I have no browser icon, and it’s not in the menu either. I also can’t seem to figure out how to actually start OctoPrint or OctoPi, whichever one is the software. I’ve found some files that indicate it’s there, but I don’t know how to use them.

What did you already try to solve it?

I have tried using the command
sudo apt-install
sudo apt-install chrome
Since I wasn’t sure if the brackets were required. Brackets caused a syntax error. The other line prompted me for my password, then returned this response:
sudo: apt-install: command not found

I read somewhere else that you can start OctoPrint by using the following command:
octoprint serve
But it also said command not found.
There is a message at the top of the command window that says to access OctoPrint from a web browser, but…I don’t have one.

Have you tried running in safe mode?

I don’t know how to do that. Also, I don’t have any plugins unless they came with the OS, I can’t install anything.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

It says:
bash: octoprint: command not found
I tried the step for adding the correct path and it just put a bracket down and now it ignores everything I type and just puts down a new line with a ’>’
I can’t get back to the previous thing with my username, anymore.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.8.7
OctoPi 1.0.0
Raspberry Pi 4b 2GB with Smartie Pi Touch 2
Printer is Prusa MK3S/+
Don’t know what firmware is referred to (the printer? The Pi? No idea either way)
Browser is none on the Pi, because there wasn’t one when it loaded the GUI, and Chrome on the PC
OS is OctoPi? And Windows 7 Home Premium on PC

Everyone online said this was so easy to do, and it really, really isn’t. I have spent hours trying to get this to work, and it does the strangest things, and no matter what I look up, nobody has seemed to have had ‘quite’ the same problem as me, at any stage. I’m probably doing something really basic, but there are no guides that detail the part where I’m struggling (or Google is hiding them from me!). Sorry, just very frustrated.

A typical OctoPrint install is on a device that doesn't have a screen, and it runs a web server that you can access from other devices on your network. It should start automatically when the OS (OctoPi) boots up, and when you see the message about opening OctoPrint in a web browser, you can type the IP address into another device connected to the same network to access OctoPrint's UI.

I would try and make sure you can access OctoPrint the 'normal' way before trying to install a desktop & browser locally - it's possible, if that's what you want to do, but rather than type out an essay to explain everything at once I think it's easier to do one step at a time.

Having never used octopi I tried it recently.

The first hitch in doing so was that I had to find and identify the IP address of the pi so I could connect my browser to it.

The second hitch was that octopi runs the octoprint server to connect at the standard http://pi.ip.address URL while my installation of octoprint on ubuntu had used http://ubuntu.ip.address:5000.

Once I realized that octopi did not use the port to connect to octoprint (or rather it redirected to the proper port) then things were golden.

Additionally, you should be able to connect to octopi with ssh and manage it from the command line as well as through the octoprint interface. Really easy and does not need the overhead of running the gui interface on the pi.

Octopi is clean and easy to use and understand. No frills, which is ideal for a server.

Thank you, I appreciate your explanation. Literally nothing that I’d read elsewhere made it clear that OctoPrint was designed to run that way (accessible from another device and not from the device itself) and I was tearing my hair out.

I had seen multiple options for running OctoPrint from a touchscreen with a plugin, I take it that doing this on the same device where OctoPrint is installed would require the essay-length explanation?