Trouble setting up wi-fi with second octoprint/raspberry pi 3


#1

Version 0.15.1 for both instances. I'm running them on separate Raspberry Pi 3 units.

I had one unit working well and decided to purchase a second printer and its own raspberry pi 3/octoprint instance. The first unit still works well, but I cannot get the second installation to work on wi-fi (have not tried using ethernet). I changed the hostname on the second unit to "machine2" and left the original unit as "octopi" I set up the wi-fi network name and password using the txt file just like I did on the first unit that is working.

When I log into my routers, I don't see the second raspberry pi, but I do see the first as "octopi."

Any ideas?


#2

Hi,

you could check if your R-Pi can "see" the WiFi at all by issuing the following on the CLI

sudo iwlist wlan0 scan | grep ESSID

That should list all SSIDs of WiFi networks the R-Pi can receive. If its not showing there you cant connect to it. Unless ofc you hide the SSID but fo the sake of testing you could enable it just to make sure the R-Pi can actually see the network. If your SSID shows up you can in the next step issue the same command without the part "| grep ESSID", you should find a line like this:

Quality=70/70  Signal level=-31 dBm

The signal level is the most important part here for now, the higher the number the worse the signal, -30 dBm is a good signal, -80dBm is bad. If you are around the -80 or worse the R-Pi might receive your WiFi but due to the R-Pi's very tiny antenna the WiFi device might not be able to reveive the R-Pi. Relocating it might help or remove obstructions etc.....

Regards
Jan P.


#3

And another thing just came to mind, not all R-Pi 3 support 5 GHz WiFi, is your WiFi 2.4 or 5 GHz ?

Jan P.


#4

Thanks for the troubleshooting pathways. I punched those commands in and did indeed see my wi-fi network in the list. Didn't move onto the signal strength, as my printer is about 5 feet away from the router, and I have successfully printed with the other octoprint/raspberry pi over 100 feet away through concrete walls.

What ended up resolving this for me was likely configuring the wi-fi using the GUI under sudo raspi-config. I also changed the keyboard layout so that I could use the pipe in the commands in you listed, but I certainly hope that was not what resolved my problem!

I'm using the same raspberry pi 3 model for both instances, so the first one wouldn't work if there were an issue with 5GHz wi-fi, right?


#5

You can can find out the exact version of R-Pi if you issue cat /proc/cpuinfo and look at the revision at the bottom. The R-Pi 3B+ is the only with 5GHz, that's revision a020d3. I believe it also has a metal heat spreader on the bigger chip top side.

Revision Numbering

Re GUI for WiFi settings I would not know, I am a CLI guy ;-).

network={
ssid="network_name"
psk="Pre_Shared_Key"
}

Something like the above would have to be in /etc/wpa_supplicant/wpa_supplicant.conf with YOUR credentials. Reboot and you should be good to go assuming you use DHCP to get an IP Address.

Regards
Jan P.