Trouble when i upload a file

Hello i run a MK3S with octoprint (last update).
I am having trouble with some files, the last one is a 33mb gcode.
I had multiple failed print who ended like this : Communication error
Printer kept requesting line XXXXXX again and again, communication stuck (can't put 2 images in the same post since i am new here).

I resliced it, reoploaded it but always fail like this.
Then tried to put it on a SD card, it worked perfectly fine with the exact same gcode.

I had a hunch, i tried to grab the file with the download option of the print list in octoprint.
And if i check the file on a gcode viewer i can see some very strange line appears.

If i check the original file i can't see anything like these lines.
It seems that when i upload this file it get corrupted or something like that.
Do you have any idea what it could mean? (i am using firefox as my interface with octoprint)

Logs. Give us logs or we cannot help.

The error message you mention is about the communication between OctoPrint and the printer, not about uploading the gcode file from your slicer to OctoPrint. It is not about anything in the the gcode file itself, but about your printer saying it is not hearing what OctoPrint is saying.

octoprint.log (172.2 KB)

Here is my log, i am not very skilled in octoprint but the line 12365 seems to cause problem.

Somehow your gcode files seem to get corrupted. It could be that the sd card in your raspberry pi is broken.