Trouble with file manager

What is the problem?

Since the Octoprint 1.4.1 upgrade, when I delete a file or upload a new one for print, the list will not upgrade and the status bar keeps rolling until I restart Octoprint then the new file shows or the old one disappears. Is this a known problem or just mine? I am a new user so forgive me if I am not using the correct method of finding out problems. This did not happen prior to the new version of Octoprint.

What did you already try to solve it?

I have not tried anything to solve it yet as I wanted to find out first if anyone is already looking at this.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Try safe mode. If that works it's one of your installed third party plugins. If for some reason you still have the GCodeEditor plugin active, disable that, it's known to cause precisely that kind of problem in its current versions.

Hi, Sorry about that it seems that the new 1.4.2 has fixed the issue.

Nope, you just probably had GCodeEditor installed and that is currently blacklisted due to this precise issue, and updating and restarting made OctoPrint reload the blacklist and not load the plugin :wink:

Thank you for your fast reply to this question. I want to add that I love working with Octoprint.

Brian Johnson

I now have a new problem that I couldn’t find on your site. I am getting a Forbidden message and cannot access Octoprint. It shows as there when I look at fing. But my computer cannot access. Any suggestions?

I was having the same issue and disabling Gcode editor worked for me. I had previously disabled plugin Theimify thinking that was the culprit but it looks like this is the one. Thanks!