Trouble with ports on local network [SOLVED]


#1

What is the problem?
Unresponsive web interface
What did you already try to solve it?
Different browsers, different operating systems
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
OctoPrint 1.3.10 running on OctoPi 0.15.1

Hi all,
I have an Octopi connected to an Anet A8 printer.
As I understand it, pointing a browser at it from another computer on the local network should bring up the web interface, allowing me to add files, print, view webcam, control the printer etc.
When I do this sometimes I get the interface, sometimes just an unresponsive page theat looks like I need to log in. Tried this and still unresponsive. When it works, it only does so for a short time then freezes up, refreshing gets me back to the basic octoprint page.
I also have on my home network another couple of Raspberry Pi's
One runs nextcloud (among other things)
Nextcloud uses ports 443 and 80 the same as octoprint.
I think I would like to change the ports octoprint uses to something else to try and avoid a port clash with nextcloud.
How would I manage this, the information I have found is confusing.
Thanks
Rev


#2
  • The Raspberry Pi which is connected to the Anet A8: we need to know what model that is. A Raspberry Pi Zero W only has a single core and could be the problem if that's the case. A Raspberry Pi 3B would be what I'd recommend since it has four cores.
  • "pointing a browser from another computer": You could be more specific here, as in what kind of computer and what kind of browser?
  • How is this Pi connected to your network (Ethernet cable or wi-fi)? How is your computer connected to your network (same)?
  • "sometimes just an unresponsive page that looks like I need to log in.": A picture is worth a thousand words, as they say. Upon bootup or restarting OctoPrint, it takes a moment for OctoPrint to get going. Until it's completely ready it will display very spartan screens which indicate that it's not ready yet. For a one-core Raspberry, this process takes longer.

Whether or not a second Raspberry Pi is running services on 80/443, this shouldn't matter for the first Raspberry Pi which is serving OctoPrint.


#3

I'm using a Raspberry Pi 3B+ on the printer (new a week ago)

The PC I'm using is a dual boot Windows 10/Linux Mint machine, Ryzen 2400G, 16Gb memory, 500Gb SSD. I don't use windows much.

The browsers I've tried, Windows - Chrome, Firefox, Edge. Linux - Chrome, Firefox, Epiphany (all latest versions)

The Pi3B+ (printer) is connected wireless, SSH enabled and no issues with connectivity. The PC is wired.

I have a Pi2B running kodi wired. A Pi ZeroW running kodi wireless, a Pi3B+ running nextcloud (1Tb USB HDD), transmission, couchpotato, sabnzbd, sickrage, test website. This is also wired. Along with my phone (android) and a rarely used old laptop which access the network.
Fibre broadband with wireless/wired hub.

As for the spartan screen, very good description! that's it perfectly, even after waiting 15 minutes it stays the same. The Pi3B+ on the printer is using an official PSU as I thought power might be an issue.
When it is running the elapsed time clock counts for about 10 seconds the freezes. I have used a few different SD cards and fresh images to eliminate a dodgy card.

Rev


#4

What we know

  • Your PC (Linux) is wired via Ethernet to your network as well as the Pi2B and a Pi3B+ (not related to OctoPi).
  • Your Pi3B+ with OctoPi is wireless as well as a Pi Zero W.
  • Your network router is responsible for moving traffic between the wired side of things and the wireless side of things.

What we don't know

  • We don't know if your Linux install has Bonjour as a name-resolution service. This would be handy for converting a hostname like "octopi.local" into an IP address.
  • We don't know if your router is causing the hiccups in traffic.
  • We don't know if your wifi zone is 2.4Ghz or 5Ghz. The Raspberry Pi 3B+ now supports 2.4Ghz/5Ghz but the Zero W only does 2.4Ghz.

As a troubleshooting step, it would be great to physically connect the 3B+ to Ethernet to see if this works great. If so, then treat this as either a wonky wifi setup (competition with your neighbors?) or perhaps there are things in your house which are reflecting back the wifi signals or blocking them.


#5

Sorry Sir :wink:
afaik "Bonjour" isn't necessary under Linux this is such a "apple-thingie" :thinking:


#6

Thanks for the help, really useful.
The issue is a lost cause, I'll live with it.
Rev