Troubleshooting Octopi after getting new Wifi Router


So last week I came back from vacation and noticed that my wifi router died.
I ordered a new one and got new wifi network up and running.
My problem now is, that I can´t get my Octopi to connect via Wifi

-I tried editing the octopi-wpa-supplicant.txt
It didn´t help.

-So I completely reset the sd card.

-I reedited the txt file.

  • Still won´t connect

  • I connected the Octopi directly with an Ethernet cable and it worked.

I don´t know what my problem is.
I´m using a Raspberry Pi 3 Model B ARM-Cortex-A53

hope you have all the info you need.

are you using the same ssid/key? did you change from open to WPA/WPA2?

Here's my file:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

I changed it to the new setup

You need to help me out with what you mean with your file?
If you mean the content of the octopi-wpa-supplicant.txt file, mine is:



down at the bottom somewhere I removed the # symbol at my country.
it now says:

country=DE # Germany

Everything else is original

Are you sure it just hasn't assigned it a new IP address that isn't the same as the previous one?
Also, did you comment out the country=GB line with a # at the front?
If not rfkill is shutting wifi down due to having multiple countried listed

You´re comment sparked an Idea.
It was just a new IP adress for my Octopi.
But it didn´t display neither in "advanced IP scanner", nor the config site of my modem.
I Was able to find the IP adress at the config site of my new wifi router.
Now it´s working again

Thanks a lot!

1 Like

Glad I could help!

Great you did it!
So could you please: