Trouvleshooting$$

What is the problem?

WRITE HERE
Need help badly! Little background new to this bought ender 3v2 just recently got it printing consistently then I bought raspberry pi 4b worked great booted up with noobs on a monitor and everything then I tried to image octopi and it kept saying incorrect login so I went to micro center and bought a preloaded octopi sd card. Put that in and it said required new version (what was the point of buying that if I have to download new one?)I have not changed that sd card I tried to image a different sd with octopi on raspberry imager again like before and now the raspberry pi will not boot with any of them even the original which worked fine before and the printer does not load anymore it’s stuck on the Creality logo. Please if anyone can help my fix this I will pay them to get it working properly thanks everyone

ReplyForward

What did you already try to solve it?

WRITE HERE
watched bunch of videos tried different users passwords tried different configurations in the raspberry imager

Have you tried running in safe mode?

WRITE HERE
YES

Did running in safe mode solve the problem?

WRITE HERE
NO

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
ender 3 v2 and raspberry pi 4b
WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
WRITE HERE
windows 10 pls help$$

1 Like

Hi
First of all that's nothing serious - you just got stuck somewhere. Nothing is broken. :slight_smile:

Let's try to get the pi to boot up. Disconnect all usb devices from the pi and try it again. Sometimes they draw too much power so the pi can't boot up.

If it still doesn't work, tell us more about the pi. Is the sd card fully inserted? Are there any lights on the board? Are they blinking in a pattern?

Thankyou very much for the reply the pi shows a solid red light I have a keyboard and mouse plugged into it I will try booting without later when I get home

The sd card is fully inserted and it still won’t load with no usbs connected there is a solid red light staying on

Alrighty
What happens if you also remove the sd card? Just the naked Pi 4.

What does the green light do with the SD card in ?

Same thing solid red light and no green lights the hdmi is in slot 0 and I’m using the Cana kit power cord and switch

I got the ender working again but still not the pi I tried flashing new pi os and a new sd boot also plugged directly into outlet and still solid red light im not sure what to do

Sorry for the late reply - I wasn't feeling too well.

I guess I have to correct my self. Always a red light and green not even blinking once is a bad sign.

There is one last thing that we can test:
Unlike all other Pis the Pi 4 comes with an eeprom which contains important boot data.
It could be corrupted and the reason why it's not booting.

We can try to flash new data to the eeprom and hopefully that fixes your issue.
Open the Pi imager, click on select OS, scroll down and select Misc utility images, bootloader, SD card boot.
Flash it to an sd card (preferable a 32gb card or smaller), put it in the pi and power it up.
Now wait 5 minutes, unplug it and try it again with a normal image.

Fingers crossed :crossed_fingers:

Ok thanks will try this asap do I flash a new octopi stable or try a different os after I do that

Either one is fine - both should work :slight_smile:

Ok and if it doesn’t work should I take it to micro center see if they can fix it or get into contact with canakit? Is this my fault? Cause I did get it to boot with the sd card they gave and then I tried to setup octoprint on a different card and now doesn’t boot at all, thanks get well soon

If that doesn't work it's most likely broken.
Nah you didn't do anything wrong. Most users here use their own sd card.
It's completely normal to try different images and distros :slight_smile:
That's why there are so many images to choose from in the pi imager.

Still nothing :frowning:

I’m so bad at this I re flashed the sd I used for the ender to try the pi then couldn’t get a software to load the ender again i finally I got it in Chinese switched it to English and then the g code files won’t load so I plug it into laptop and preheats then printer does nothing and I’m giving up for now

Sorry to hear that. Just return it and get a new one :slight_smile: