Trying to connect second printer to octoprint

I have one printer running fine with octoprint. I got another pi 4 and installed octopi on it and I'm trying to open octoprint and see my second printer. I've tried a couple IP addresses from my device list but nothing connects. Is it because my other printer is printing something at the moment? What should I try next? Any suggestions are appreciated. Thanks.

You mean you can't find the 2nd Pi on your netowrk? Have you checked your router to see what IP address has been assigned to it? Or plugged in a keyboard and monitor it check what IP is being assigned to the Pi? If you're trying to randomly guess the IP, well, there are 253 address left on your network (after your first pi and your router), it could be any one of them.

1 Like

Ha yup I’ll hook up a monitor and check it out thanks. I’m still pretty new to raspberry pis.

1 Like

You can also change the hostname of the pi via console :slight_smile: (either ssh or via monitor)

just enter sudo raspi-config and change the hostname via “Network Options” > “Hostname”.
Your OctoPi instance will then no longer be reachable under octopi.local but rather the hostname you chose postfixed with .local , so keep that in mind.You can navigate in the menus using the arrow keys and Enter. To switch to selecting the buttons at the bottom use Tab.

Wow that’s great info thank you very much

1 Like

So I’ve got the pi hooked up to the monitor and changed the name to dhoctopi.local. Still can’t see the IP address. How do I reveal the address? Also I can’t connect to dhoctopi.local in my browser. Thanks!

If you have two RPi computers in the same network with the same name, the DHCP server (usually your router) can get confused. Other systems can also get confused. Changing the name on one of the RPi computers helps, but the MAC address hasn't changed so the router may still be confused. Rebooting the router should help and then reboot any other systems that are still having trouble.

I figured it out. I’m so dumb and forgot to uncomment one more line in the wpa supplicant. After doing that, the IP address came right up. Crazy. All is well now. Thanks for all your guys’ help though! Happy printing.

2 Likes

For future reference, from the RPi command line, you can use ifconfig to get your currently assigned IP address as well as other network info.