Trying to develop a way to connect to the creality K1 board.

So, I did A LOT od modifications on software and firmware, it's running a modded firmware, that allows me to ssh into root mode of the board. It runs on some sort of modified linux version, using a modified version of moonraker, klipper and Fluidd. By the modification, I have connected the printer to OctoEverywhere, and can make it connect to Klipper with some caveats. I also saw some sort of unused serial port, which I was unable to identify because it was too small to be a micro usb, and too big for a type C. But the main USB serial port can be exchanged for another like micro or the one the ender series use. In this case, Do you guys think it would be possible to connect octoprint to it? Since it runs on Klipper and Fluidd?

I never used Klipper so I'm not really an expert in that field.
But I would just disable the fluidd service so it doesn't start automatically anymore and install OctoPrint.
You can either do it yourself or use this script

Is that script for Linux Arm? The K1 runs on a proprietary Pi-like processor, but it has an MIPS processor, which has a different set of instructions, so the normal scripts won't work without some modifications. This is the example of that: a modified install script of octoeverywhere modified to work on the MIPS processor. GitHub - mikebcbc/K1-OctoEverywhere: Octoeverywhere install script for the Creality K1.

hm the script is for linux in general and in theory the architecture shouldn't matter.
As long as the OS supports python 3.7+ it should work fine.

But mips? Really Creality?

Afaik you need Python 3.7, Python 3 pip and nice to have is Python 3 venv.
All the other components will be downloaded via pip and should be platform independent.

edit: just read the github link. seems like the system is missing a few thing the octoprint deploy script might need.

I expected it to be a "normal" debian based OS just on a mips cpu.

If all necessary packages are already installed it's not hard to install OctoPrint.
But if you need some by hand it could be a bit a bit fiddly

That's basically the debian install guide:

I tried it, and it stopped midway because it did not have enough storage space. Apparently the board has a VERY limited amount of RAM (256MB of LPDDR2). I don't think it will be possible to install octoprint directly. Refer to print about board specs:

I think probably the most feasible approach would be to try to serial connect with Klipper OS, via direct serial, or maybe even open a port via wifi so they could connect.


Unfortunately I can't help you with the connect to OctoPrint part.
I hope someone else can help you :slight_smile:

You can also try it on the Klipper Discord

@kantlivelong was working on a direct socket connection plugin from OctoPrint to Klipper. Might be a good use case here.

So, I'been off, but still trying things and there has been some updated on the K1's situation:

  1. creality released the source code for the K1 klipper modified firmware, and some annex explaining the board pin outs and how to root, how to install/uninstall both Mainsail and Fluidd.
  2. Somebody on reddit did a reverse engeneering and found some unused pins, that according to him, he was able to get a tty console for boot logs and a terminal session. GitHub - ballaswag/k1-discovery
  3. Tried usb connetion to with the rasp via both frontal usb and the micro usb on the side of the board, unable to get this modded klipper on this modded rasp monstruosity to recognize the usb device.

Still trying to find a way. Will go over to klipper forum, since it appears to be something on the modded klipper that is not allowing for usb connections. lsusb on the K1 returns: Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

If the @kantlivelong does complete this direct socket connection, it may be possible, or if one of the Klipper folks finds out how to unlock the USB ports on the K1 series modified Ingenic X2000 boards, since the code is out. If the Klipper folks respond about this I shall update here.

This is a bit old, but since I posted this over about a question with the KE I figured you might find it useful as well. There is a rooted firmware out for the K1, Max, and KE by Destinal.

Your best bet would be to install Octoprint alongside the Fluidd install, but the CrealityOS is a bit jenky. Destinal stated he is working on a Debian-based replacement for the CrealityOS distro that would make adding Octoprint much easier.