Two internal private networks, WebUI won't work from one

I have two private subnets set up at my home. is mostly wired connections. is mostly wireless connections.

My octoprint is wireless with IP
With a laptop connected wireless and getting an IP in subnet I can open the WebUI fine.
With devices on the subnet trying to connect to octoprint WebUI the webpage responds with "File is not found. please enter correct url."

From these same PCs on the subnet I can make an ssh connection to octoprint so it is not a connectivity issue.

This was working fine until a few weeks ago. Thinking back, maybe this was working while I was using the release candidate version and stopped after updating to the current GA release.

Since I mainly use a linux workstation on the wired network for slicing, I would like to resolve this issue.

Has anyone else run into this or have suggestions on why the WebUI is giving me this response?


This totally sounds like your router, to be honest.

  • You could simply add an Ethernet cable to the Pi and see if it works from both private networks
  • Note that the Avahi hostname broadcasting service won't be propagated from one private network to another, so consider issuing a static IP address and entering a hosts file entry on your laptop/workstation

If you needed to, you could issue two IP addresses to the Pi (wifi & Eth) and then add two entries to your hosts files:        octopie.local # Note the "e"        octopi.local octopi

And then just visit the one that works for you given the particular circumstance.

Thanks for the suggestion. I added those to /etc/hosts, but set all to Maybe you had a typo with Shouldn't all be the same?

I tried opening WebUI with each of those three host names. For each I got the unsigned certificate dialog but again received the same page thereafter.
I'm just not sure what is different now then several weeks ago when this worked fine between the two subnets.

Not a typo, I.T. people routinely issue static IP addresses from the top of the range. Often could be the highest available address but I personally just issue from 200 and go lower, myself.

Okay, so now you're saying "unsigned certificate" which leads me to believe that you're trying to use https as the protocol rather than http. Try just:


So I determined this is not an issue in the Octopi. I installed tcpdump and with that found the http requests were never making it to the octopi. Determined that the netgear nighthawk router/access point that sits between the two subnets was sending back this message.

Didn't want to fight this any more so moved the Octopi to the subnet.

1 Like