Two things, settings not saved and time lapse


#1

First problem is that I'm signed into my account on a few PCs, one local (localhost), one on the same network (192.168. ,,,etc) and one remotely with my computers IP address. When I launch a print, I set feedrate to 70% and Extrusion to 110%, but if I sign into another computer, both these settings reset to 100%, causing potential issues with the quality of my prints. I'm running latest everything.

Second issue is that, I just don't understand how to make the timelapse work, I have my camera plugged in, I can see it in the camera tab and both testing for stream and snapshot work, but timelapse just doesn't start. Same with Octolapse.


#2

I can help with Octolapse issues probably, but I'll need a few things: your gcode file, your settings.json file (OctoPrint settings[wrench icon]->Octolapse->Download settings), and a log file from the failed print. Also let me know what printer you are using, what version of OctoPrint, and what hardware you are running (Pi3b/windows/mac etc).

To get the log, run a short test print, but change the Octolapse debug profile to 'Full Diagnostic - Test mode', which will prevent extrusion, heating of bed and nozzle, fans, etc. Make sure you unload your filament though in case there are compatibility problems! After the print is complete (should be a very small print, like a calibration cube), you can go to Octoprint Settings(wrench icon)->Logs and dowload plugin_octolapse.log. Post all three files and I'll check it out.

If this isn't a standard configuration issue I may ask you to re-post to the Octolapse issues page on github.

Thanks!


#3

Hey there.

About your first issue, it's not an issue at all. It's just the way it work. When you log in from another computer it doesn't change your extrusion or feed rate. It just doesn't show the changes you've made from another computer. This is because the printer itself doesn't give feedback to octoprint from these changes. It's diffucult for you to see this, but it's the same behavior with the fan, and with this it's easyer to see. If you start a print with fan at 100%, changes it to 50% and then connect from another computer, you will see that fan will show 100%, but it's still spinning at 50%, unless you move the slider or change the value.

If printing with this values of flow rate and feed rate is a constant, you should set this at your slicer, or better yet, calibrate your printer e-steps to correct values so you just change this values eventually to compensate differences from a new filament or fine tuning.


#4

They're only set to 100% in the UI, your printer should still be at whatever you set it to. This is a byproduct of most 3d printer firmware being (for the most part) one way communication. Most 3d printers don't have any way of querying them about what the current feed/flow multipliers are and so octoprint can't possibly display anything accurate. The only things you can really query out of most printers is the temperature and the current eeprom settings for things like steps/mm, the only way to accurately know what the feed/flow rates are set to is if the printer has an LCD display, to look at that.

On a side note, if you constantly have to adjust those multipliers, you need to fine tune your slicer. You shouldn't ever have to rely on the feed / flow rate multiplier for every print.