Typical error........failed to autodetect serial port, please set it to manually

Hey guys!
Fairly new to using octoprint. Had an Army buddy help me set it up (he is deployed now and i cant bug him about this). I have tried changing usb cords and all the usb ports on the pi. I am using a rasberry pi v3 and connecting to and ender 3. I have looked through some forums but cant figure out where to type dmesg command. I figured it would be on the terminal tab, but the terminal tab doesnt allow me to type anything. I just fired the printer back up after four months of not using it, it connected right away. I did the updates and now it wont connect. sorry for posting the same problem that looks to have been posted a ton of times before, but i am struggling here. thanks in advance for the help.octoprint.log (177.5 KB)

Moved topic to the appropriate category.

You communicate with OctoPrint with a web browser. OctoPrint is an application running on a host, usually a Raspberry Pi. The host is running an operating system, often OctoPi and to communicate with the OS, you need either a keyboard and monitor attached directly to the RPi or you can use SSH to establish a virtual terminal connection. On Windows, the program used most often is PuTTY. There's an equivalent program for MacOS.

The dmesg command is an OS command and would be entered using the virtual terminal established with PuTTY.

I'm using a surface pro with Windows 10. I can connect to the RPI, but the rpi is not connecting to the printer.

There are numerous threads detailing the steps required to troubleshoot OctoPrint's failure to connect to a printer. Please do a little research and then post the required logs (<-- link).

thanks for the help B-Morgan. in my original post i stated that i had read through other posts and forums and have tried the options that other people have suggested as well as posting my log, in fact the name of my post is actually called typical error. please do a little reading before offering help.

I'm sorry I missed your OctoPrint.log in the initial post. In over three hours of log, the error octoprint.util.comm - INFO - Changing monitoring state from "Detecting serial port" to "Error: Failed to autodetect serial port, please set it manually." occured 40 times.

I quote from the logs link:

  • serial.log : A log of all of the communication going on between OctoPrint and your printer. Usually disabled for performance reasons, enable it through Settings > Serial Connection. Either that or at the very least the output in OctoPrint's Terminal tab is crucial for analysis of any kind of communication issues or misbehaviours observed with your printer, so it's important to include it when discussing such issues.

I'll try and improve my reading comprehension. I hope you will do the same.