UI Timelapse delete is not actually deleting the underlying files

Camera model

Arducam B0205

What is the problem?

When I delete a file in the UI it appears to work, I can see the 200 response status from the API call, but the file is still there.

What did you already try to solve it?

checked permissions, I see drwxr-xr-x for the folder and -rw-r--r-- for the timelapse folders
tried through individual file and group file interface
turned on developer tools, looked at network tab; see the 200OK coming back to the DELETE call
turned logs into debug mode, can see tornado.access - INFO - 200 DELETE /api/timelapse/ entry
tried in safe mode, no change
not really sure which logs I can put into debug to get more info on the delete at the OS level.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20230713155311.zip (73.2 KB)

Additional information about your setup

OctoPrint version 1.9.1 (but has been an issue for a bit now)
Armbian 23.02.2 Jammy with Linux 5.15.76-rockchip64
Prusa Mk4 (also happens with MK3s+)

Is ffmpeg still running? ps auxww | grep ffmpeg?

At the moment, ffmpeg is not running. This is an issue with videos showing up after rendering is complete and persists after reboots, etc.

Does any of your file names have special characters?

check if your service file has double slashes. There was a known issue that things are not deleted when the basedir has double slashes.

just the normal chars (dash, underscore) that prusa slicer would generate. for example flat-cap_0.4n_0.2mm_PLA_MK4_37m_20230713195707.mp4 but even if I cp that to test.mp4 (and the same with the thumbnail) it fails

This was the thing!

the systemd service file BASE_DIR had double slashes in it; eliminating that made the problem go away! (both individual selection and mult-select now delete properly)

THANK YOU! An easy to work around annoyance, but it's been bothering me for a while now.

1 Like

doh, I forgot that one. think that was one I figured out on Discord.