UI unresponsive and flickering

re posting as new thread

What is the problem?

I am new to octoprint.
It works from time to time but UI is very unstable/flickering/frozen and connection to printer unstable.
I initially thought the printer connection was the issue and tried many many cables but now realised that even without printer connected there is a UI issue.
It is unresponsive and flickers, for example in safe mode the safe mode popup keeps on showing up/blinking. When I try to delete a file, the button is unresponsive and flickering lightly.

fyi connection to pi is perfect, ping, ssh and camera feed.

What did you already try to solve it?

I have tried different browsers.
I have looked at FAQ UI frozen guide.

Have you tried running in safe mode?

YES, still flickering, including safe mode popup

Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Serial log, nothing as it happens even without a printer connected

octoprint log, this is repeated endlessly
2021-02-11 03:34:36,671 - octoprint.server.util.sockjs - INFO - Client connection closed: 240b:XXX:2901
2021-02-11 03:34:37,261 - octoprint.server.util.sockjs - INFO - New connection from client: 240b:XXX:2901
2021-02-11 03:34:37,282 - octoprint.server.util.flask - INFO - Passively logging in user ysiegel from 240b:XXX:2901
2021-02-11 03:34:37,282 - octoprint.access.users - INFO - Logged in user: my login

Even when I do nothing there are constant message flows in console (may be normal... no clue!)
In console I get the below repeating at high speed:

Safe mode is active. Third party plugins and language packs are disabled and cannot be enabled.
packed_core.js?8f90e417:840 :exclamation: Reason for safe mode: settings
packed_core.js?8f90e417:844 Triggering connect on all view models
packed_core.js?8f90e417:846 Server (re)connect processed
packed_core.js?8f90e417:839 Connected to the server

in Network I get this constantly repeating at high speed:

1. Request URL:
2. Request Method:
3. Status Code:
200 OK

1. Request URL:
2. Request Method:
3. Status Code:

1. Request URL:
2. Request Method:
3. Status Code:
200 OK

1. Request URL:
2. Request Method:
3. Status Code:
101 Switching Protocols

Additional information about your setup

octoprint.version : 1.5.3
browser.user_agent : Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36


Pi 4

Ender 3 but it does not seem to be relevant...

Full unabridged logs and system info please, not just an excerpt :sob:

Here you are!

octoprint.log (105.5 KB)

serial.log (609 Bytes)

connectivity.connection_ok: True
connectivity.enabled: True
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1500.0
env.hardware.ram: 1903988736
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 21.0.1
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.version: 1.5.3

So, from the looks of it the frontend constantly loses connection to the backend and keeps reconnecting and reconnecting and reconnecting... No wonder things aren't working. Please also share your browser's error console and a screenshot of the network tab, especially from the start of the connection right at the top.

I see you are connected via IPv6, just to rule out any shenanigans on that end please try to connect through the Pi's IPv4 address (something that looks like aaa.bbb.ccc.ddd, should be listed in your router or when you SSH into the Pi and issue ifconfig).

Also, is the Pi connected via wifi or a wired connection?

What about the client/browser you are connecting from? Try a different client and browser too.

Thanks a lot for your help (and for the project!)

I have tried safari and chrome on my Mac and both do the same
I have tried my MacBook. same as my Mac.

I have tried Mac on wifi and ethernet. both do the same (although for one minute or so on wifi it was stable...). But now it does the same

I have tried Pi on wifi and Ethernet. Does not change anything.

I have just tried my iPhone on wifi and it works it seems...!!!! not sure if it is stable but I have managed to upload files and remove them few time.
I have not managed to connect to printer though... but this is something else I think, but not sure what happens now..,

Sorry, how do I connect to the Pi using Ipv4? I have done ifconfig over ssh and not sure which address is the correct one and what to do with it ...



so definitely the frontend-backend connection seems to be stable on safari iOS but not on my both Mac...

fyi I have now managed to connect to the printer in safe mode on iOS (it seems stable)
on Mac (still in safe mode) the UI is flickering as struggling to connect

Can you share the output of ifconfig? I might be able to tell you which is the correct address then.


let me know what to do with the address...

eth0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether dc:a6:32:f1:b3:8c txqueuelen 1000 (Ethernet)
RX packets 11775 bytes 4150227 (3.9 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 13767 bytes 8793102 (8.3 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 209690 bytes 117164936 (111.7 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 209690 bytes 117164936 (111.7 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::841c:9668:21f9:f2c0 prefixlen 64 scopeid 0x20
inet6 240b:10:2921:9800:157a:dade:daae:5cef prefixlen 64 scopeid 0x0
ether dc:a6:32:f1:b3:8e txqueuelen 1000 (Ethernet)
RX packets 91636 bytes 28051838 (26.7 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 93138 bytes 76522991 (72.9 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Seems to be this one. Try opening in your browser, instead of http://octopi.local. Mind you, just an absolute shot in the dark, might as well do nothing.

I now understand what you meant...

yes correct one but the shot in the dark did not hit anything... same connection issues

fyi iOS is still stable, very strange

And I have just tested on a Chromebook and it is stable... so it seems to be related to the Mac

In that case I fear I'm out of ideas. I don't own a Mac myself, and also have not observed any issues when using browserstack. Whatever this is, it's apparently something between your Mac and OctoPrint.

hummm yes I fear so
fyi on my daughter's MacBook (bigsur) on Chrome it works...!
my MacBook is on bigsur as well and it did not work on safari and chrome
so I tried getting my MacBook closer to wifi router and it worked! but where I was before I had already a good signal... and could browse internet without any issue etc

so to sum up on my MacBook it seems to work if I get close enough to wifi

so I tried again my Mac on both wifi and ethernet but none work although in both cases I have a very good network connection.

so it seems:

  • the frontend is very sensitive to wifi quality
  • for whatever reason it does not work with ethernet although the connection is very good

fyi using the IP address and ethernet cable on my Mac now seems to work... have not changed a thing...
will let you know how it goes.
Thanks a lot for your help!

Do you have any browser extensions installed that are related to security or the like? I've heard of issues with some of the antivirus extensions causing issues and if I remember correctly there was an alibaba extension that caused some weird stuff too. Try your browser in incognito mode maybe to see, as that will prevent extensions from loading.

Thanks for the suggestion, will try but i have nothing beyond translate plugin

fyi incognito does not change anything. today again it does not work, inlcuding on thernet...
hoewever I tried again connecting with the IP rather than octopi.local and it seems to work!

fyi after few weeks of usage, I just wanted to report that it works now very well when using the IP rather than octopi.local (which is always having reconnection issues)
So thanks @foosel for the suggestion!

1 Like

unfortunately I am still confronted to the same connection issue (flickering UI and unresponsive).
I really struggle to understand when and why it happens.
In the past switching to IP rather than octopi.local worked but recently it started again even if I use the IP.
It always work on my iPhone
it sometimes work on a given MacBook and not on my daughters' one...
I have checked DNS settings and they all look to be the same...
Any idea on why this happen and how to solve the issue once for all?
Many thanks!!!