Ultimaker 2 - no filament during printing


my setup:
OctoPrint version: 1.7.3
OctoPi version: 0.18.0
HW: RasbPi 4 2GB with RaspCam via flexcable
Slicer: Cura 4.13.1 incl. Octoprint Plugin.
Gcode style in Cura: Merlin
OS & Browser: Win10k prof / Firefox

What is the problem?

Everythinh seems to work but no filament is transported while printing. With start of the printig job a extrude about 20mm which works (G1 F200 E20) but ofter the nozzle goes to the middle position for print, no filament. It looks like a test run somehow.

What did you already try to solve it?

  • Changed Gcode flavour between RepRap and Merlin.
  • Changed Ultimaker firmware with an non original one and back

Have you tried running in safe mode?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.102 Safari/537.36

connectivity.connection_check :

connectivity.connection_ok : True

connectivity.enabled : True

connectivity.online : True

connectivity.resolution_check : octoprint.org

connectivity.resolution_ok : True

env.hardware.cores : 4

env.hardware.freq : 1500.0

env.hardware.ram : 1909063680

env.os.bits : 32

env.os.id : linux

env.os.platform : linux

env.plugins.pi_support.model : Raspberry Pi 4 Model B Rev 1.1

env.plugins.pi_support.octopi_version : 0.18.0

env.plugins.pi_support.throttle_state : 0x0

env.python.pip : 20.3.3

env.python.version : 3.7.3

env.python.virtualenv : True

octoprint.safe_mode : False

octoprint.version : 1.7.3

systeminfo.generator : zipapi

Hello @MuckiSG !

So please do.


Ave you Octolapse installed? Maybe it's in test mode.


same in safe mode.

System bundle

octoprint-systeminfo-20220216125655.zip (51,4 KB)

thx in advance;


I assume it runs fine when printing directly from the printer.

Can you share the gcode file? (You can zip it)

Here it is ...

UM2_Mount_Ultra.zip (134,7 KB)

The issue is:

You set the printer to absolute extrusion:

M82 ;set extruder to absolute mode

But the extrusions are relative.

So what do i have to do? Where should i change this. Waht is the difference?



First the difference:

Absolute extrusion adds all extrusion amounts and and takes this as parameter for the extrusion command.
Relative extrusion only puts the amount of filament that is used for that extruded part.

But I was wrong, the slicing actually is in absolute mode too. Sorry.

But it's this:

G1 F1500 E-6.5

The extruder rectracts, but the is no deretraction.

For test you may comment this line out in the cura start gcode script. (put a ; at the very start)


this Gcode line is not part of the Cura Start G-Code and in Octraprint i have no Start code. Here my Cura start code:

G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 Z0 ;move Z to bottom endstops
G28 X0 Y0 ;move X/Y to endstops
G1 X15 Y0 F4000 ;move X/Y to front of printer
G1 Z15.0 F9000 ;move the platform to 15mm
G92 E0 ;zero the extruded length
G1 F200 E20 ;[MK] extrude 20 mm of feed stock
G92 E0 ;zero the extruded length again
G1 Y50 F9000
;Put printing message on LCD screen
M117 Printing...

So where can i change this line of code for permanent use. Otherwise i have to save the Gcode, change it and upload it. But i will try it manully ... in the moment it prints but ....

With the start it looked like every time faulty but after some moves it printed and stoped transporting filament after a while. See picture made after aborting the process:

um2-abort.zip (304,8 KB)

very strage. By the way, the printer works from SD-card but over usb not (octoprint and direct connect to laptop).

Thx a lot 4 help!

Maybe someone in a Cura forum knows more.

Hi Ewald,

OK, i try it. I am going to give feedback if the problem is solved.

Thanks for your patient help,


Hi Ewald,

it seems to be a mechanical problem. The feeder does not hold the position. After i activated the printer i tested it with some test ptints from sd card and it worked. Then connected to OctaPrint and i got the problems as metioned. For me it was very starnge that sometimes there was some filament (several layers) and then nothing again. Because of the fact it worked from sd-card i did not regard to mechanical problems.

Then i made several tests and even from sd-card i got no filament. But and that is strange till now, when i say "extrude some filament" within the menu, it works.

In Reddit i got the hint to have a look on the feeder because this part often makes problems. I disassembled it, cleaned it and tested some settings with the screw and now it works better but not reliable.

Then somebody told me that the filament might be to old. I used 2 years old but originally, factory packed PLA (incl. the dry pad). Could this cause also problems? A combination of old PLA and feeder?

Thanks a lot for patience!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.