Unable to boot OctoPi in PI 4B

What is the problem?

Got a Raspberry P4 B+ board 4 RAM
I can't load/boot any of the OctoPI builds available.

What did you already try to solve it?

Tried with all flavors available going from 1.5 to 1.17 to 1.18 RC4 and nightly builds, tried in both flavors 32/64 bit at no avail.
I can successful load the normal PI builds so i can conclude that my board got no problem.

Have you tried running in safe mode and if so did it solve the issue?

No, i did not

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


What happens if you try?
Did you connect a display to see if any error is displayed?

The screen flikkers and stay blue ending with a 'no signal' messages.
I just reinstalled PI with the PI installer, it boots fine, i got a screen, touch does not work tho.
Sadly i got no extra screen to connect direct to HDMI, i use a Miuzei 5" screen now. That seems to work (without touch) bit PI raspberian loaded normal.

Did you install the driver or whatever package that comes with the screen?

I can't get to do it yet because it can't boot into Octopi.
Ordered an other screen today but i am pretty sure its the octopi image that give a problem.
I could try with a P3b board to see if that is the cause, need to wait arrival as wel.
Like i mentioned earlier, The normal PI build boot, just as the bootimage that Miuzei provide.

Considering that these images work fine for literally tens to hundreds of thousands of users out there, I have a bit of doubt there.

How are you flashing? Please describe the exact steps you take, starting from when you download the zip. Explain like you are explaining to someone who never has done it before so they can copy exactly what you did.

Download zip, unpack it and use balenEtcher to copy the IMG to a 32GB disk, partition is done by Etcher and reduces the 32 to a smaller format.
After that i just push the miniSD card into the slot.
I doe realize that OctoPi works for so many people, i just wonder what could be the cause with mine :frowning:

When you try to boot up the Pi, what do the LEDs do? Which colors do you see, do they blink, stay on solidly, stay off?

Have you verified the checksum of the downloaded image zip(s) against the published one on the download page?

They start Red first, then green en orange flikkering, after few seconds only the red is lighted.
When i use
For the moment i am rearranging the board into it's case an gone try to connect the screen bij HDMI instead of the 26 pins connector from the screen. See if that could be the reason, so I'll make a one on one HDMI.
I get back on this after doing the assembly and try again.
Btw, i bought the labists kit.

As you can see, the PI 4b works and the screen works, 32 Pi raspberry latest.
OctoPi does not.
Still have to try with another screen but seeing taht this one works i can rule out that the screen is the culprit.

Here you can see, the led turns red and green, screen goes blue/black blinking and ends blinking with the red led on!

OctoPi doesn't ship with a desktop preinstalled, it is meant to be used headless over the network. Configure wifi as outlined in the setup instructions, try to access it then. So far it really sounds like your display is simply not being recognized and everything else working just fine.

Could you try another HDMI display? Perhaps your TV or desktop monitor?

Thx for the reply, planning to connect it with my TV later tonight.
I installed Octoprint on my Windows laptop, that works like a charm. Just wanted to install it on my PI, but like i say, i could not see anything so i concluded it was not working. I was also a bit mislead by the messages over the bluescreen issues people encountered?
I'll keep you updated.
Thanks for the info.

I'll do later today.
Let you know the outcome.

Connecting to my TV seems to work :slight_smile:
at least i can login now. For sure there must be a driver issue with my little tft touchscreen.

Make sure you install the desktop, as it says in that little intro message once you login. That might be all the problem is (famous last words), the other screen doesn't support the console output.

1 Like

Thank you all for the answers. Appreciated

1 Like