Unable to connect Ender 3 S1, unable to autodetect

What is the problem?

Unable to connect to printer, no serial port found. Printer was used for about 2 weeks(new), then sat unplugged for a few months. Now unable to connect to printer. Getting 'No working connection parameters could be found'.

What did you already try to solve it?

Reinstalling fresh Octopi
3 different USB cables
running dmesg

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20221119021326.zip (15.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint V1.8.9, OctoPi V0.18.0 on Raspberry Pi 3 Modebl B Plus Rev 1.3, Ender 3 S1 Firmware V1.0.3_C, Microsoft Edge, Windows 11 Home

was anything detected?
you can enable a continuous dmesg output with dmesg -w.
Also make sure that the printer is turned on.

From what I could understand from the help guide on the issue, no. I can reply with the readout later as currently at work.
After initial post I also updated firmware to mriscoc’s most recent build. And tried plugging into computer to see if USB device was recognized, no luck.

I am thinking it’s a faulty port. I’ve seen a couple ideas of wiring directly from the main board to the Pi via gpio/serial. Could this be a solution instead of buying an all new mb?

Yeah for sure. If the board doesn't have dedicated serial pins, you can most of the time use the ones for the serial to usb converter.
Here is an example

sounds weird - running latest Octo on RPi4 on a stock 3S1Pro so the host commands are not enabled as discussed in so many forum posts - but everything works fine. Auto connect, load to SD or Pi and run jobs etc.

I am not a techie so no skills when it comes to doing anything other than plug it in and run.

are you sure your cable is OK?