Unable to connect to CR10 V2 from Octprint

What is the problem?

Printer had been working excellently. latest updates all applied. prints successful. Turned printer back on after a day or so and unable to connect to the printer -

No serial port found, are you sure your printer is physically connected and supported? Try [refreshing](javascript:void(0)) and if that doesn't help please see the FAQ.

What did you already try to solve it?

Confirmed cables are functional for data and USB port works on Pi.

pi@octopi:~ $ dmesg | tail -n 20
[ 7973.948410] usb 1-1.3: new high-speed USB device number 4 using dwc_otg
[ 7974.090594] usb 1-1.3: New USB device found, idVendor=13fe, idProduct=5100, bcdDevice= 1.00
[ 7974.090647] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 7974.090663] usb 1-1.3: Product:
[ 7974.090678] usb 1-1.3: Manufacturer:
[ 7974.090692] usb 1-1.3: SerialNumber: 07032AEDB40AB738
[ 7974.092746] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[ 7974.099009] scsi host0: usb-storage 1-1.3:1.0
[ 7974.161067] usbcore: registered new interface driver uas
[ 7975.332747] scsi 0:0:0:0: Direct-Access PMAP PQ: 0 ANSI: 4
[ 7975.351964] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 7979.639168] sd 0:0:0:0: [sda] 60532992 512-byte logical blocks: (31.0 GB/28.9 GiB)
[ 7979.639477] sd 0:0:0:0: [sda] Write Protect is off
[ 7979.639497] sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00
[ 7979.639795] sd 0:0:0:0: [sda] No Caching mode page found
[ 7979.639814] sd 0:0:0:0: [sda] Assuming drive cache: write through
[ 7980.091177] sda: sda1
[ 7980.094948] sd 0:0:0:0: [sda] Attached SCSI removable disk
[ 8361.242059] usb 1-1.3: USB disconnect, device number 4

Following this the I tried plugging in the printer again and no further changes or connections with Printer.

Have you tried running in safe mode?

Yes no change. Octopi not connecting

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20230102003352.zip (25.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version : 1.8.6
OctoPi version : 0.18.0

Board - Creality3D RAMPS
Baud: 250000
Protocol : 1.0
PSU : Generic

FirmWare - Marlin
2.0.5_NIC
2020-04-10

I was able to make the Pi connect to the Cr10 v2 via this methoud

remove power blocker from PI
Power down printer
reboot Pi
Connect to printer with power off
Power on Printer
Reconnect to Printer.
dmesg | tail -n 20

[63181.035435] Under-voltage detected! (0x00050005)
[63303.755305] Voltage normalised (0x00000000)
[63307.915463] Under-voltage detected! (0x00050005)
[63399.439263] Voltage normalised (0x00000000)
[63405.909830] ch341-uart ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32
[63405.909945] ch341-uart ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32
[63406.104894] usb 1-1.3: USB disconnect, device number 4
[63406.105325] usb 1-1.3: failed to send control message: -19
[63406.105876] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
[63406.105958] ch341 1-1.3:1.0: device disconnected
[63412.289415] usb 1-1.3: new full-speed USB device number 5 using dwc_otg
[63412.422494] usb 1-1.3: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
[63412.422518] usb 1-1.3: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[63412.422534] usb 1-1.3: Product: USB Serial
[63412.426288] ch341 1-1.3:1.0: ch341-uart converter detected
[63412.436870] usb 1-1.3: ch341-uart converter now attached to ttyUSB0

1 Like

Could it be that the voltage from your Printers board / Powersupply is lower than it should be. Maybe the communications replys from the Printer is just at too low a voltage for the Pie to pick it up. Now with the positive side of the USB is connected you see warnings on the voltage which might mean that the Pi is now pulling up the boards TTL to a level that allows things to communicated.

This may be something that is working for you but I would say it's not a good situation. The investigation and solve of this is pretty technical as well. Maybe with the "power blocker" installed you could measure the 2 sides of the power on the USB side to see how different they are. If the cases is as I suggested above, you would see a lower voltage on the printer side and it may change over the course of a print while the power supply is taxed a little.