Unable to connect to printer


#1

Hi All,

I've been using Octoprint since November on my Ender-2.

Unfortunately a hardware failure meant I had to replace the printer board, and was sent the newer board (Creality V1.1.2) which doesn't like the smaller screen.... so it all works, but I can't see anything on my display.

However, I've been ok controlling it with Octoprint on my Zero-W without any problems. Trouble is, I didn't realise you're supposed to shut down before powering off and corrupted my sd-card. Lesson learned.

I've got a new card, re-installed Octo and allowed it to update. Trouble is, now it won't connect to the printer and comes up with the error "Offline (Error: SerialException: 'device reports readiness to read but returned no data (device disconnected or multiple access on port?)' @ comm.py:_readline:2417)"

I've tried the things I've read about, but nothing has worked;
It works fine direct to the PC and prints via my slicer on there (though it doesn't have the printer controls that Octo gives).
I've tried a different power supply (though I've been using the same one that been fine so far)
The cable is ok, as it's the one that works with the PC.
No changes have been made to the printer from when it was working previously.
I've tried manual settings instead of auto.
With the printer power off, plugging the Pi in powers the board as it always has.

Any help would be appreciated :slight_smile:


#2

Did you install OctoPrint or the OctoPi image that's setup for a Pi?

I suppose it goes without saying that the serial cable needs to be plugged in at both ends.

Does the Creality come pre-flashed with Marlin or are you expected to do so? This sounds like it came with Marlin since you've indicated that you can use it direct to the PC. You'd think an older version of Marlin would still work with OctoPrint.

Is this the same serial cable that you used back in November or a different one?


#3

Hi, Thanks for the quick answer!

Installed with the Pi image, low level format then normal format on the card first. Octo itself runs ok, it updated and allows me to access it as normal.

The board came raw, I installed the bootloader and Marlin - Octoprint has been fine with it until I knackered the memory card by not shutting down Octoprint before powering off - that's the strange thing, it was working fine :confused:

It's the same cable, though I've now also tried a 2nd with the same result. I'm currently waiting for my Ender 3 to stop it's print so I can try it on there too and see if the issue is printer-specific.

I've just finished trying a 2nd install on another card, exactly the same error.

Very confused.


#4

That error looks familiar and while I can't find it now, I think there's something that you can do to fix it. Either a plugin or a settings change in OctoPrint. Feed the error message to Google and see what it spits out.