Unable to connect via serial

What is the problem?

Serial connection seems to connect and send M110 but printer does not respond. I have run into this issue periodically over the past year and its usually because Marlin-bugfix broke something and eventually is fixed from a commit.

What did you already try to solve it?

  1. Tried different USB cables.
  2. Put tape over the 5v pin and took it off.
  3. Safe mode and regular mode.
  4. Changed serial ports and baud rates in Marlin (250000 and 115200)
  5. Verified I am running Python 3 in my Octopi instance
  6. Updated Octopi with apt full-upgrade
  7. Fully reinstalled fresh Octopi/Print with newly downloaded image on different SD card.
  8. Turned off suggested settings Request Exclusive Access and Request Low Latency and back on again.
  9. Tried everything I could find in the FAQ regarding serial connection issues and read as many posts I could of users with similar symptoms.
  10. Tried direct connecting via pronterface/repetier host with similar failure symptoms from them both. Can see printer on the usb serial but no response from M110.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

It did not.

Systeminfo Bundle

octoprint-systeminfo-20211016121734.zip (1.1 MB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Printer: Two Trees Sapphire Pro (CoreXY)
Printer Mainboard: MKS Robin Nano V3
Printer Firmware: Marlin 2.0.x (10/15/2021 build)
OctoPi: Version 0.18.0, running on Raspberry Pi 4 Model B Rev 1.4
OctoPrint: 1.7.0
Browser: Brave - Version 1.30.89 Chromium: 94.0.4606.81 (Official Build) (x86_64)
System Version: macOS 11.6 (20G165)
Kernel Version: Darwin 20.6.0
Myself: Tyler, Male, 36, Gemini, Left-Handed-!

I just figured it out. It's because I'm left-handed...

You may try to connect the printer to a PC running pronterface.

You're not alone, I've been fighting the same issue all day. Printer has ran fine for months but today it will not connect to Octoprint.

Yes I did that too actually sorry I forgot to list that. The printer will also not connect through pronterface or repetier-host. Seems to be the same outcome with both of those. Can see the printer on USB but when handshaking gets not response and either times out or continues trying different baud rates.

Did you update octoprint or marlin and the result was not being able to connect? Or was it completely random that you can't connect as well? We'll get through this :slight_smile:

Then it seems that there is something wrong with the printer's firmware.

Yes I agree. I kind of knew that already just from past experiences that were similar and resolved themselves from just waiting a day and flashing new nightly of Marlin.

Although this time I flashed stable release Marlin ( which is only 13 days old so still a rather new release, and that won't connect either. I'm usually on the bugfix builds and that is understandable to have broken things.

Either way I think its safe to say its the firmware's problem and not Octoprint. But without reporting this kind of stuff to the multiple layers of the stack, I guess we wouldn't be learning anything from anything huh?

Thanks for the help!

Seems my AtomicPi needed several updates, once updated I was able to connect. I also had to complete a PID calibration to get the printer back in working condition.

Thought I replied earlier via email. Oops.

Is that AtomicPI regarding the SPI library? When I try enabling these in Marlin:
#define USE_UHS3_USB

It spits out this error to me:

#warning "Your SPI library installation lacks 'SPI_ATOMIC_VERSION'. Please complain to the maintainer." [-Wcpp]

Any relation to what you are referring to?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.