Unable to get Octopi to boot

Even though I am 76 years old, I feel like an infant. I recently purchased a Creality CR-10 3D printer and have been able to do several prints. Recently I read about how a Raspberry Pi can be used to monitor various activities during the print cycle including monitoring the print process with a cam. I just purchased the Raspberry Pi 3+ kit so I can incorporate it into my prints. Here are my initial issues. I cannot seem to be able to correctly flash Octopi to my 32 GB SD card. I've tried it several times. and cannot get the Pi to boot. I've tried using several image programs, including Raspberry Pi one but am unable to boot the Pi after trying to flash Octopi several times. Also, I have tried to flash the basic Pi OS and can't get it to boot.

I've tried several different SD cards and still get the same results.

Attached is a picture showing the most recent attempt to boot Octopi. I don't know enough about the OS to understand the various lines on detail.

I sure would appreciate some advice on how to proceed.

Thanks in advance.

Hello @jdv007 !

Is that the complete boot up sequence?
For this indicates that the boot is starting, but not if there is an error.

Can you wait until there comes nothing more and send another screen shot?

So we know that OctoPi is not the issue.

This in combination with trying multiple different applications to flash multiple different sd-cards with more or less the same result makes the most logical explanation that the Raspberry Pi that you have is broken.

1 Like

There is no more boot up code. I see 3 raspberries at the top of the screen, indicating that the Pi started to load, but then stopped for some unknown reason.

I thought i read somewhere that the Pi devices are all quality checked at the factory before shipping. Apparently that's not the case?
Thanks for your response.

Does anyone else have additional suggestions?

Checked at the factory reduces the chances of a "dead on arrival" failure but it doesn't eliminate it. That is why warranties exist and it sounds like you need to communicate with the seller and get a replacement.

Doesn't each raspberry at the top of the screen represent one CPU core and doesn't the RPi 3B+ have four cores?

It looks like the 1st raspberry (of 4) is hidden by the overscan of the display.

OK gentleman. After many hours of effort, requesting Amazon to replace my original Pi 3B+, I am able to finally able to boot up the Raspberry Pi OS. Here's some background. I was unable to boot up the current Pi OS release with either of the Pi 3B+ units. Same with the latest version of OctoPi. I tried an older version of the Pi OS, specifically the 2018-11-13-raspbian-stretch release. So my first question is why was I able to boot up the older OS release, but not the current version (Raspberry Pi OS (32-bit) / 2021-01-11)?

The next issue is the inability to boot the current version OctoPi (octopi-buster-armhf-lite-0.18.0) on either the two Raspberry Pi 3B+ devices from Amazon. I have tried countless times to burn the image to both an SD card and a USB drive with no luck. I haven't tried to install an older version to see if that will work, but the question is why can't I burn a workable image of either of these two OS's? So far I have only failed boots that either go to the rainbow screen or it boots up to 4 raspberry images and several lines of screen dump.
Sure would greatly appreciate if someone could help me find some answers. I'd gladly send my phone number to any one who has some solutions and is willing to discuss this directly with me.
Here's another update. After booting my device using the older version of the RPi OS, I did allowed it to do an update once logged in. After doing the updates I had to do a reboot and the pi would not boot.

Thanks advance.

Might be that some components are faulty. With older image these are not used during boot but with newer one are?
I'm thinking of memory mainly. Try booting with "older" image and run a mem test.

This might help:
(arm64: defconfig: enable memtest Β· raspberrypi/linux@822bf48 Β· GitHub)

Keep in mind that I have the same results with 2 different Rpi 3b+ devices. Seems to me that it is unlikely that both of them would have faulty memory chips, no?


BTW: What program do you use to bring the image to the SD card?

I used Raspberry Pi Imager to create the image on SD card.

Both the rainbow screen and all the lines of text are correct, there is no GUI installed by default on the OctoPi images so you will just get a console login. If there is an error, then it might be useful to say what the error is so we have a better clue.

OK, now I'm starting to make progress with getting a successful boot with both the Raspberry Pi OS and Octopi/Octoprint. The problem is I am unable to get the must current images of both of these OS's to boot. I was able to successfully able to boot the following images for these 2 systems:

  1. Raspberry Pi OS - 2018-11-13-raspbian-stretch
  2. OctoPi - 2018-11-13-octopi-stretch-lite-0.16.0

Again, I am attempting to flash the current images to the Raspberry Pi 3B+. I have two of these devices and neither will boot with the current versions of these 2 OS's.

Can anyone suggest a solution to my current issue?

Thanks in advance,

I don't know of a solution to your issue but I've been able to boot both of my RPi 3Bs and my RPi 3B+ with the latest OctoPi image.

I'm using Windows 10 (64). After downloading, I checked the MD5 checksum using winMD5sum and it was correct. I used Etcher to flash the image to a 32GB micro-SD card, removed and inserted the micro SD card (to get the /boot partition to appear), and used Notepad++ to edit octopi-wpa-supplicant.txt. I inserted the micro-SD card in each of my 3 RPi systems (with the power off), turned the power on and they booted. I connected with Chrome and finished the first time setup on the first RPi. I logged in using SSH (PuTTY) and shutdown the RPi before moving to the next one.

I hate to say it but maybe Amazon has received a batch of bad (or counterfeit) 3B+ systems.

might be an option: use the old image and execute updates on it?
See if that keeps working after updates
updates to do:

  • os level: "apt update; apt upgrade"
  • octoprint itself

I had the same issue with a Raspberry Pi 3A+, I have tried to install Octopi 0.18 with Octoprint 1.8.4 (build 20220927151125) multiple times via Raspberry Pi Imager without any succes, it just would not start up.

Strangely, my first attempt worked successfully but I was not able to connect via hostname so I tried to re-install and after that no booting of Octopi/RPi.

Installing a nightly version solved thisfor me.